Problemi compilazione superkaramba

3 risposte [Ultimo messaggio]
Ritratto di Alessio
Alessio
(Geek)
Offline
Geek
Iscritto: 04/11/2005
Messaggi: 107

Salve a tutti

sto cercando di compilare superkaramba e ottengo alcuni errori, qualcuno l'ho già risolto da solo ma altri no, ad esempio ./compile finisce con questo messaggio
checking for Qt... configure: error: Qt (>= Qt 3.3 and < 4.0) (headers and libraries) not found. Please check your installation!

che mi pare significhi che la versione di Qt che ho installata non rientra tra la 3.3 e la 4, guisto?

Controllando con yast mi trovo questa installazione riguardo a Qt:

qt3 | 3.3.7-42.1 | 10.8 M
python-qt | 3.5.6-22.5 | 10.1 M
libqt4 | 4.2.1-18 | 2.6 M
libqt4-dbus-1 | 4.2.1-18 | 368.9 K
libqt4-debuginfo | 4.2.1-18 | 249.6 M
libqt4-devel | 4.2.1-18 | 19.5 M
libqt4-devel-doc | 4.2.1-18 | 4.3 M
libqt4-qt3support | 4.2.1-18 | 3.0 M
libqt4-sql | 4.2.1-18 | 219.8 K
libqt4-x11 | 4.2.1-18 | 8.4 M
libqt4-devel-doc-data | 4.2.1-7 | 50.5 M

che sembrano essere tutte fuori del range indicato, sempre se ho capito bene....

Adesso non mi ricordo ma mi sembra che tutte queste libreirie e pacchetti mi siano state richieste da un'altro programma che ho installato ma non ricordo quale...

Come posso fare per risolvere?

Tra l'altro di errori di compilazione ce ne sono altri, almeno presumo che siano errori perchè alcune righe riportano no come risòutato ma, visto il poco inglese che conosco, probabilmente alcune vanno bene così.

Va bè, cominciamo con Qt, mi aiutate a risolvere per favore? Big Grin

Alessio Forconi

E questa cosa del software libero senza steccati... è bellissima!!! Big Grin

Ritratto di Alfio
Alfio
(Guru)
Offline
Guru
Iscritto: 30/08/2005
Messaggi: 2678

Perchè non installare la versione di guru o nel pacchetto kde kdeutils3-extra 3.5.5-34 o versione successiva?
Ciao

Ritratto di Alessio
Alessio
(Geek)
Offline
Geek
Iscritto: 04/11/2005
Messaggi: 107

Grazie Alfio.
Quote:

Alfio ha scritto:
Perchè non installare la versione di guru o nel pacchetto kde kdeutils3-extra 3.5.5-34 o versione successiva?
Ciao

Per la verità non ci avevo nenche pensato, qual'è il repository?

In ogni caso vorrei cominciare a cimentarmi con le compilazioni perchè non si può restare sempre un niubbo... si deve crescere e linux mi piace assai.... come potrei risolvere il problema?

Alessio Forconi

E questa cosa del software libero senza steccati... è bellissima!!! Big Grin

Ritratto di Alfio
Alfio
(Guru)
Offline
Guru
Iscritto: 30/08/2005
Messaggi: 2678

Quote:

Alessio ha scritto:
Grazie Alfio.
Quote:
Alfio ha scritto:
Perchè non installare la versione di guru o nel pacchetto kde kdeutils3-extra 3.5.5-34 o versione successiva?
Ciao

Per la verità non ci avevo nenche pensato, qual'è il repository?

In ogni caso vorrei cominciare a cimentarmi con le compilazioni perchè non si può restare sempre un niubbo... si deve crescere e linux mi piace assai.... come potrei risolvere il problema?

La maggiorparte di quei pacchetti li trovi nel dvd di openSuse in rpm.
Oppure ecco il repository da aggiungere.

http://download.opensuse.org/distribution/10.2/repo/oss
Ciao