Programmi multimediali NON funzionano per vedere i film.

15 risposte [Ultimo messaggio]
Ritratto di Nighthack
Nighthack
(Junior)
Offline
Junior
Iscritto: 24/09/2007
Messaggi: 15

Ciao a tutti.
Hò un problema molto strano.
Non riesco a vedere nessun film!
Il formato in generale e avi, e i programmi che uso sono.
vlc
mplayer
Smplayer
kaffeine, pero senza i kodec non gli ho ancora installati.
Con l'appertura di qualsiasi tipo di film (formato) si chiudono subito,
l'unico che non si chiude è Smplayer, però, riesco solo add ascoltarlo, e non riesco a vedere nulla.
PS.
ho installato anche un programma di screencasting, recordmydesktop, e giro qualche video, , mahh
quando mi da i file .vob, li posso vedere con mplayer, ma lo schermo va e viene, con delle onde , non so come spiegarlo, fa come i vecchi film in bianco e nero, dove lo stream va e viene velocemente, cosa che è assolutamente sgradevole.
Ancora un PS.
Spesso lo screen fa la stessa cosa anche quando viene fuori il screensaver.
Vi prego di aiutarmi.
cosa devo fare?

SuSE RULEZZZZ 8-)

Ritratto di sunrots
sunrots
(Guru)
Offline
Guru
Iscritto: 04/01/2005
Messaggi: 510

Quote:

Nighthack ha scritto:
Vi prego di aiutarmi.
cosa devo fare?

Si deve, tanto per cominciare, seguire quanto indicato in questa guida.
http://www.suseitalia.org/modules/wfsection/article.php?articleid=135
Utile poi dare una occhiata anche alle altre guide, possono uscirne spunti per risolvere altri problemi (e per impratichirsi un pò).
Saluti,

sunrots

Non più attivo qui. Mi troverete su http://it-opensuse.org Wink

Ritratto di wal7er
wal7er
(Guru)
Offline
Guru
Iscritto: 21/09/2007
Messaggi: 572

Risposta semplice:
se non lo hai gia' fatto aggiungi il repo packman
installa xinelib1 al posto di quello di defaul xine-lib
installa win32codecs

Vediti tutti i video con tutti i formati conosciuti

NB:
ci sono tanti lettori ma ti consiglio kaffeine

HP Pavilion dv5-1110el powered by OpenSUSE 13.2 64bit

http://linuxcounter.net/cert/432576.png

Ritratto di Nighthack
Nighthack
(Junior)
Offline
Junior
Iscritto: 24/09/2007
Messaggi: 15

Grazie, (visto che vlc è un codec di sè , pensavo che non era un problma codec, ma adesso che ho installato tutti i codec, e riavviato funziona)
rimane un ultimo problema, il problema dello schermo.
Voglio dire che lo streaming non è stabile, cioè è come se qualcuno averbbe manomesso i frames e nelle prime 30 era normalmente fungente poi, una frame di blackscreen.
Non so se ci siamo capiti, durante il video vengono molto spesso problemi, e il film continua a LAMPEGGIARE e non mi da tregua.
NON è un problema codec, visto che anche quando cè lo screen saver (che non centra niente con i codec) succede la stessa cosa.
ho installato i driver proprietari di ati, e configurati seguendo una delle vostre guide, e funziona alla grande con compiz.
Non so se centra con i driver, o la configurazione, comunque anche con effetti
disabilitati succede la stessa cosa.
Questo come lo risolviamo?
Vi prego nuovamente di aiutarmi.
So qualcosina su linux, pero non sono un geek.

SuSE RULEZZZZ 8-)

Ritratto di wal7er
wal7er
(Guru)
Offline
Guru
Iscritto: 21/09/2007
Messaggi: 572

Vlc e' un player che al suo interno ha dei codec per visualizzare i files.
Puoi anche dire a vlc di usare xine per la decodifica.
Se usi vlc ed hai abilitato le opzioni per far funzionare a dovere compiz prova a cambiare il dispositivo di uscita video di vlc e settalo a xvideo o xshm (non ricordo precisamente i nomi ma per tentativi dovresti trovare la configurazione vincente).

HP Pavilion dv5-1110el powered by OpenSUSE 13.2 64bit

http://linuxcounter.net/cert/432576.png

Ritratto di Nighthack
Nighthack
(Junior)
Offline
Junior
Iscritto: 24/09/2007
Messaggi: 15

Ho seguito il tuo consiglio, e adesso uso kaffeine cosi ho disinstallato completamente vlc, e anche il vlc mozilla plugin,
Apro con kaffeine e lo schermo continua a lampeggiare.
Se mi ricordo bene questo problema e nato dopo aver installato recordmydesktop, provo a disintallarlo e vedo che succede.

SuSE RULEZZZZ 8-)

Ritratto di wal7er
wal7er
(Guru)
Offline
Guru
Iscritto: 21/09/2007
Messaggi: 572

Se usi kaffeine vai impostazioni -> parametri motore xine -> video
qui puoi slelzionare quale driver usare (usa shm per maggiore compatibilita' con compiz)

Comunque se ti piace di piu' vlc poi usare quello: uno non esclude l'altro anche perche in qualche raro caso un file viene aperto con un programma e con l'altro non funziona.

N.B.:
Se ti voi vedere anche i dvd con kaffeien e/o gli altri lettori
da qui http://www.pluto.it/files/ildp/lfs/blfs/6.0/multimedia/libdvdcss.html
ti scarichi libdvdcss, te lo compili e te lo installi

HP Pavilion dv5-1110el powered by OpenSUSE 13.2 64bit

http://linuxcounter.net/cert/432576.png

Ritratto di Nighthack
Nighthack
(Junior)
Offline
Junior
Iscritto: 24/09/2007
Messaggi: 15

Nota,
Ho installato tramite repo
i seguenti.
libxine1 --k3b-codecs- -Mplayer-- Mplayer-plugins --k3bmonkeyaudioplugin--w32codec-all --audiokonverter-- vlc--vlc-mozillaplugin--libdvdcss--Timidity
Dopo vedevo i video ma con il schermo che lampeggiava.
Dopo o disinstallato sempre via repository vlc e vlc mozillaplugin ancora i filmati lampeggiavano.
Dopo o disinstallato recordmydesctop, e adesso, non riesco manco ad aprire i video.
la cosa risulta stranissima.
:-o
non riesco veramente a capire dove sia il problema..
Cmq, la causa di tutto questo credo che sia recordmydesktop.
qualche idea?
Ps quando vado su settings, impostazioni motore xine kaffeine si chiude,
:-o

SuSE RULEZZZZ 8-)

Ritratto di wal7er
wal7er
(Guru)
Offline
Guru
Iscritto: 21/09/2007
Messaggi: 572

A questo punto prova rimuovere gli ultimi programmi che hai installato e reinstalla solo kaffeine, libxine1 e win32codecs.
Cosi' dovrebbe funzionare

HP Pavilion dv5-1110el powered by OpenSUSE 13.2 64bit

http://linuxcounter.net/cert/432576.png

Ritratto di Nighthack
Nighthack
(Junior)
Offline
Junior
Iscritto: 24/09/2007
Messaggi: 15

Grandioso, ti ringrazzio motlissimo.
Adesso funge.
Ho fatto tutto quello che mi ai detto dopo sono andato e ho modificato su video i driver e ho messo xshm come driver.
Big Grin

SuSE RULEZZZZ 8-)

Ritratto di wal7er
wal7er
(Guru)
Offline
Guru
Iscritto: 21/09/2007
Messaggi: 572

Quindi adesso e' risolto.

HP Pavilion dv5-1110el powered by OpenSUSE 13.2 64bit

http://linuxcounter.net/cert/432576.png