(Risolto) Mi manca il comando "make"

25 risposte [Ultimo messaggio]
Ritratto di cicciolinuks
cicciolinuks
(Geek)
Offline
Geek
Iscritto: 12/06/2010
Messaggi: 198

Salve a tutti.
Neanche a dirlo, ho installato oggi il mio primo linux che intendo usare per abbandonare windows, ed ovviamente ho dei problemi che anni fa, quando per un breve periodo installai Suse non ebbi (non so se opensuse sia lo stesso).

Allora, come dice il titolo, mi manca il comando make. Voglio evitarvi di leggere cosa penso su una cosa così importante che manca, quindi metto qualche dettaglio, per sapere se qualcuno può aiutarmi. scrivendo:

cnf make

ottengo la :
------------- FASE 1 --------------
Il programma 'make' può essere trovato nei seguenti pacchetti:
* make [ percorso: /usr/bin/make, repository: zypp (repo-oss) ]
* make [ percorso: /usr/bin/make, repository: zypp (openSUSE 11.2-0) ]

Try installing with:
sudo zypper install make

------------- FASE 2 --------------
scrivo (senza capire, ma confidando nella fortuna): sudo zypper install make

zypper: error while loading shared libraries: libzypp.so.619: cannot open shared object file: No such file or directory

domanda: E adesso?

Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

hai interrotto qualche aggiornamento?

apri yast e reinstalla zypper e libzypp dovrebbe risolverti il problema.

zypper ad ogni modo è il programma a linea di comando per la gestione del software (apt-get su ubuntu)

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el

Ritratto di cicciolinuks
cicciolinuks
(Geek)
Offline
Geek
Iscritto: 12/06/2010
Messaggi: 198

Non ho interrotto niente, comunque il sistema qui ha qualcosa di strano. In basso a destra ho un triangolo giallo con un punto esclamativo che dice "Unable to get transaction for packagekit".
Quindi all'avvio mi dice che ci sono degli aggiornamenti, ma per qualche errore questi non si installano.

Quando su yast ricerco i pacchetti che mi hai detto (con Webpin), seleziono tali pacchetti, premo "avanti" e... la finestra sparisce. Ho anche provato ad installare l'RPM di flash, col tasto destro avvio con l'installatore e non succede niente...

Ritratto di bagarozzo85
bagarozzo85
(Guru)
Offline
Guru
Iscritto: 16/06/2006
Messaggi: 1050

Ciao,

domande:
- hai eseguito aggiornamenti del sistema? Se sì, quale procedura hai seguito?
- satsolver-tools è installato? Se sì, quale versione?

PS: make non è installato di default perché non è previsto che l'utente normale debba mettersi a compilare per avere il software standard. Per installare la toolchain è possibile andare in YaST -> Software -> Visualizza -> Pattern, selezionare Sviluppo C/C++ e premere avanti.

Ritratto di cicciolinuks
cicciolinuks
(Geek)
Offline
Geek
Iscritto: 12/06/2010
Messaggi: 198

Brutta notizia:
da yast -> software
non vedo la voce "visualizza", tuttavia non è questo il problema, infatti l'unica opzione che mi funziona è la ricerca pacchetti webpin (almeno la prima schermata, poi si chiude da sola quando, scelti i pacchetti, clicco su "avanti"). l'errore che ottengo sul resto delle voci del menu "software" è il seguente:
-- "Error while creating client module add-on"

Per le tue domande. Io ho solo installato opensuse, e non ho fatto altro per quanto riguarda gli aggiornamenti. Un messaggio mi ha avvisato della presenza di aggiornamenti, ma solo cliccando sul messaggio che mi avvisa degli aggiornamenti, ottengo l'errore:
"DBus error : Unable to get transaction id from packagekit."

satsolver-tool non so nemmeno cosa sia

Ritratto di enziosavio
enziosavio (non verificato)
()

Hai installato da DVD hai controllato l' md5sum?
O hai usato una Live ?
Strano non funzioni zypper????'
Se vai nel terminale e scrivi " su " senza virgolette
e poi zypper ref e ancora zypper dup
non fa niente ...
Il triangolino giallo indica che hai qualcosa che blocca kupdateapplet .....
fai destro sul triangolino > controlla adesso

Ritratto di cicciolinuks
cicciolinuks
(Geek)
Offline
Geek
Iscritto: 12/06/2010
Messaggi: 198

Ad ogni nuovo intervento viene fuori una parola nuova, sconosciuta alle mie orecchie. Anche questo (purtroppo) è linux.
Non so cos'è l'md5sum, ho messo il dvd ed ho fatto partire l'installazione, il resto è storia.

Se clicco sul triangolino-> controlla adesso ho un simpatico messaggio di errore.

La mia sembra una situazione disperata, reinstallo tutto prima con opensuse, poi proverò altre distribuzioni.

Grazie per il vostro aiuto, se dopo la reinstallazione opensuse mi funzionerà mi rileggerete qui.

Esperante (ne tre multe ...)
---------------------
Kial al mi ne eblas havi iun ajn Linukson sen problemojn??

Ritratto di enziosavio
enziosavio (non verificato)
()

http://translate.google.it/translate?hl=it&sl=en&u=http://en.wikipedia.org/wiki/Md5sum&ei=7Y4UTM2sHsiXOMHTqckM&sa=X&oi=translate&ct=result&resnum=1&ved=0CCAQ7gEwAA&prev=/search%3Fq%3Dmd5sum%26hl%3Dit
Non scappare subito.........
I comandi che ti ho dato non funzionano??????????
L' md5sum è per controllare se il Dvd che stai usando per installare no è corrotto.........
Da qui http://software.opensuse.org/112/it scarichi il Dvd e poi scorri la pagina e trovi checksum md5
dove ti da una serie di numeri e lettere che deve corrispondere a quelle del Dvd che devi masterizzare......
Lo masterizzi con Windows ?
Ci sono dei programmi per Windows che lo verificano.........fai una piccola ricerca in Google (md5sum con windows)

Ritratto di cicciolinuks
cicciolinuks
(Geek)
Offline
Geek
Iscritto: 12/06/2010
Messaggi: 198

Allora, prima di riavviare l'installazione ho visto che c'era un'opzione per il controllo dell'integrità del dvd.
L'ho fatta, e mi dice che il DVD è corrotto (che forse è la cattiva traduzione in italiano dell'inglese corrupted -- si può avere un contatto con i traduttori di suse per le correzioni?). Quindi, il dvd è il primo dei problemi.

Allora, siccome da qui riesco a vedere le partizioni windows, proverò a rimasterizzarlo. Purtroppo windows non si avvia più, perché siccome si è bruciato un modulo della ram, l'ho tolto. E secondo windows, windows non può partire con queste impostazioni hardware (che sono esattamente le stesse di prima a meno di una bacchetta di ram).

Ritratto di enziosavio
enziosavio (non verificato)
()

Prima devi riscaricarlo dal link che ti ho dato..........
Poi controlli md5sum ...... e solo allora lo masterizzi per poi installare.......
Ciao Buon lavoro

Ritratto di cicciolinuks
cicciolinuks
(Geek)
Offline
Geek
Iscritto: 12/06/2010
Messaggi: 198

Porca miseria ho già fatto partire la masterizzazione sulla stessa immagine. Quindi sto perdendo un altro dvd.