Sorpresa... problema skype 4.3 sordomuto

31 risposte [Ultimo messaggio]
Ritratto di cicciolinuks
cicciolinuks
(Geek)
Offline
Geek
Iscritto: 12/06/2010
Messaggi: 198

Premetto che ho il problema da settimane e non ho scritto per non rompere le scatole con un problema ormai classico e del quale nessuno vuole rileggere. Ho cercato nel forum e su google. La famosa guida SDB:Skype stavolta non funziona.

Allora, alcune settimane fa il vecchio skype è andato in pensione con tanto di motivo ufficiale ed email Microsoft. Ho installato la versione 4.3.0.37 (attualmente l'ultima) che però mi permette solo di scrivere e leggere; posso effettuare chiamate ma tanto non emette né "sente" alcun suono. Completamente sordomuto. Addirittura se faccio una chiamata di prova, il mixer di KDE mi dice che nessun dispositivo sta emettendo suoni.

Non ho cambiato niente, ho disinstallato la versione vecchia e messo quella nuova, che ha subito presentato il problema. Poi ho reinstallato i pacchetti come da guida:

sudo zypper install pulseaudio alsa-plugins-pulse alsa-plugins-pulse-32bit pavucontrol libv4l libv4l-32bit libv4l1-0 libv4l1-0-32bit libv4l2-0 libv4l2-0-32bit libv4lconvert0 libv4lconvert0-32bit

Niente. Nelle impostazioni di skype, Dispositivi Audio, mi fa scegliere solo Virtual device per ogni dispositivo (microfono, altoparlanti, suoneria).

Idee?

PS Opensuse 13.1 con KDE

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 880

Pavucontrol > configurazione >Audio interno > stereo analogico Output
Verifica anche Uscite e ingressi

Ritratto di cicciolinuks
cicciolinuks
(Geek)
Offline
Geek
Iscritto: 12/06/2010
Messaggi: 198

Pavucontrol non si avvia.

Fatal error: Unable to connect to pulseaudio: ok

Forse è il problema. Magari lo disinstallo...

---
MODIFICA: l'ho disinstallato e non funzionava più l'audio, reinstallando skype si reinstalla anche pulseadio e sono al punto di partenza. Se lancio pulseadio da riga di comando:

pulseaudio
W: [pulseaudio] authkey.c: Failed to open cookie file '/home/utente/.config/pulse/cookie': File o directory non esistente
W: [pulseaudio] authkey.c: Failed to load authorization key '/home/utente/.config/pulse/cookie': File o directory non esistente

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 880

Usa yast > harware > suono > abilita pulseaudio e controlla i livelli > riavvia

Ritratto di cicciolinuks
cicciolinuks
(Geek)
Offline
Geek
Iscritto: 12/06/2010
Messaggi: 198

Ma con KDE?
Io ho trovato:
Yast > hardware > hardware information > sound > e poi informazioni sull'hardware e nessuna opzione di tipo software che potrebbe riguardare pulseudio

----------
PS c'ho gmerlin Alsamixer ed alsamixer che funzionano. Ma anche alzando tutti i volumi non va.

Ritratto di Arin
Arin
(Junior)
Offline
Junior
Iscritto: 18/11/2009
Messaggi: 44

Salve a tutti,
installa il pacchetto skype*.rpm non con zypper , ma dal terminale, per vedere le dipendenze mancanti, ricordati di installare con yast quelle che terminano con *-32.rpm, perché sckype funziona solo a 32 bit.
ES: pulseaudio-32bit libqtweb-32bit d-bus-32bit e altre che non ricordo At Wits End

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1691

Arin ha scritto:

Salve a tutti,
installa il pacchetto skype*.rpm non con zypper , ma dal terminale, per vedere le dipendenze mancanti, ricordati di installare con yast quelle che terminano con *-32.rpm, perché skype funziona solo a 32 bit.
ES: pulseaudio-32bit libqtweb-32bit d-bus-32bit e altre che non ricordo At Wits End

Esatto, poi carica anche i devel corrispondenti. Skipe mi funziona, su diverse macchine, da dio sia 3.1 standard che avanzato sia 32 che 64bit.

Off-Topic: Comunque consiglio Ekiga e Linphone.

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di cicciolinuks
cicciolinuks
(Geek)
Offline
Geek
Iscritto: 12/06/2010
Messaggi: 198

Forse mi arrendo. Non capisco perché l'audio funziona per qualsiasi programma e skype fa così.

Faccio:

yast -i skype-4.3.0.37-suse.i586.rpm

Mi appare una schermata blu e cerco le dipendenze (nel secondo menu, non ricordo il nome). Sono le seguenti, che comunque mi dice che sono già soddisfatte (nel primo menu).

skype - Skype is free Internet telephony that just works (che fai, mi provochi? Quando funzioni?)

Provides: config(skype) = 4.3.0.37-suse121, skype = 4.3.0.37-suse121, skype(x86-32) = 4.3.0.37-suse121
prerequires: /bin/sh, /bin/sh
requires: libQtCore.so.4, libQtDBus.so.4, libQtGui.so.4, libQtNetwork.so.4,
libQtWebKit.so.4, libQtWebKit4, libQtXml.so.4, libX11.so.6, libXext.so.6, libXss.so.1,
libXv.so.1, libasound_module_pcm_pulse.so, libc.so.6, libc.so.6(GLIBC_2.0),
libc.so.6(GLIBC_2.1), libc.so.6(GLIBC_2.1.3), libc.so.6(GLIBC_2.2), libc.so.6(GLIBC_2.3),
libc.so.6(GLIBC_2.3.2), libc.so.6(GLIBC_2.3.4), libc.so.6(GLIBC_2.4),
libc.so.6(GLIBC_2.7), libdl.so.2, libdl.so.2(GLIBC_2.0), libdl.so.2(GLIBC_2.1),
libgcc_s.so.1, libgcc_s.so.1(GCC_3.0), libgcc_s.so.1(GLIBC_2.0), libm.so.6,
libm.so.6(GLIBC_2.0), libm.so.6(GLIBC_2.1), libpng12-0, libpthread.so.0,
libpthread.so.0(GLIBC_2.0), libpthread.so.0(GLIBC_2.1), libpthread.so.0(GLIBC_2.2),
libpthread.so.0(GLIBC_2.3.2), libpulse0, librt.so.1, librt.so.1(GLIBC_2.2),
libstdc++.so.6, libstdc++.so.6(CXXABI_1.3), libstdc++.so.6(GLIBCXX_3.4),
libstdc++.so.6(GLIBCXX_3.4.9), xorg-x11-libXv, xorg-x11-libs, config(skype) =
4.3.0.37-suse121, libqt4 >= 4.6, libqt4-x11 >= 4.6, rpmlib(CompressedFileNames)

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1691

Mi pare che alcune cose le compila, dunque quelle dipendenze devi caricare il corrispondente devil
Angel

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di Arin
Arin
(Junior)
Offline
Junior
Iscritto: 18/11/2009
Messaggi: 44

delle dipendenze che hai trovato, controlla che siano installati i corrispettivi pacchetti da 32bit.
Se avevi opensuse a 32 bit non c'erano problemi, ma se ai invece la x64 devi installarli tu manualmente tutti gli *-32bit.rpm corrispondenri alla lista che hai sopra Nerd

Ritratto di cicciolinuks
cicciolinuks
(Geek)
Offline
Geek
Iscritto: 12/06/2010
Messaggi: 198

Tutti tutti non li ho controllati, ma di quelli che ho visto ho entrambi le versioni 64 e 32 bit. Devo disinstallare le 64 bit?