virtual box non parte

5 risposte [Ultimo messaggio]
Ritratto di di0nis0
di0nis0
(Geek)
Offline
Geek
Iscritto: 04/04/2006
Messaggi: 95

ciao ragazzi premetto che e la mia prima esperienza su virtual box ma appena installata la versione 2 se clicco sull icona questa non parte, l ho fatta partire da shell e ho scoperto che non avevo i permessi poiche i file su cui puntava erano di root,ma una volta fatta partire da root mi da un errore di creazione di alcuni file ossia ...non parte

come posso fare???

p.s. ho fatto il downgrade alla versione 1.5 che invece mi parte ma quando voglio (dopo aver creato l immagine) installare il sistema operativo(nel mio caso volevo provare solaris)mi salta fuori che i driver per virtual box non sono della stessa versione di virtual box ,ma invece se vado a vedere la versione e la stessa

ho installato: virtualbox, virtualbox-kernel, virtualbox-tool , x11-driver-virtualbox

manca qualcosa???

ciao e grazie :-o :-o

Ritratto di deckard
deckard (non verificato)
()

Il problema è che il repository di virtualbox dove hai preso la versione 2 ogni tanto fa uscire aggiornamenti che creano quel problema. O rimani alla 1.4, o spetti che esca la patch della patch o fai come me, come tra l'altro ha suggerito Anubis, cioè installi la versione che trovi sul sito di virtualbox. In questo caso devi anche installare i sorgenti del kernel, make, gcc... perchè altrimenti nascono altri problemi.
Ciao.

Ritratto di di0nis0
di0nis0
(Geek)
Offline
Geek
Iscritto: 04/04/2006
Messaggi: 95

ciao ragazzi ora sono tornato alla 1.5 ma se la faccio partire da utente mi esce :

The VirtualBox kernel driver is not accessible to the current user. Make sure that the user has write permissions for /dev/vboxdrv by adding them to the vboxusers groups. You will need to logout for the change to take effect..
VBox status code: -1909 (VERR_VM_DRIVER_NOT_ACCESSIBLE).

Result Code:
0x80004005
Component:
Console
Interface:
IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}

che devo fare????

Ritratto di di0nis0
di0nis0
(Geek)
Offline
Geek
Iscritto: 04/04/2006
Messaggi: 95

scusate ma per questo errore ho risolto ho aggiunto l utenza al file group

ora pero e sorto un altro problema mi dice di avviare il VBOXDRV

ma appena da root do:

/etc/init.d/vboxdrv setup

ottengo:

Stopping VirtualBox kernel module done
Recompiling VirtualBox kernel module, NOT. It has been packaged. done
Starting VirtualBox kernel module failed
(Kernel module not found)

che faccio???

Ritratto di wal7er
wal7er
(Guru)
Offline
Guru
Iscritto: 21/09/2007
Messaggi: 572

Se vuoi installare virtualbox rimuovi tutti i pacchetti installati tramite yast e ti scarichi il pacchetto rmp dal sito: c'e' quello per opensuse 10.3 e 11 nelle versioni a 32 e 64 bit ed e' tutto incluso.
Le versioni presenti su yast sono un po' vecchiotte e senza il supporto usb (versioni completamente open).

HP Pavilion dv5-1110el powered by OpenSUSE 13.2 64bit

http://linuxcounter.net/cert/432576.png

Ritratto di deckard
deckard (non verificato)
()

Apri una shell e dai:

su

per loggarti come root.
Poi dai:

<br />zypper search virtualbox<br />

Dovresti avere un risultato del genere:

<br /><br />zypper search virtualbox<br />Lettura dei pacchetti installati...<br /><br />S | Nome                           | Sommario                        | Tipo<br />--+--------------------------------+---------------------------------+----------<br />i | VirtualBox                     | Powerful PC virtualization so-&gt; | pacchetto<br />  | virtualbox-ose                 | VirtualBox OSE is an Emulator   | pacchetto<br />  | virtualbox-ose-guest-tools     | VirtualBox guest tools          | pacchetto<br />  | virtualbox-ose-kmp-debug       | Kernel Module for VirtualBox    | pacchetto<br />  | virtualbox-ose-kmp-default     | Kernel Module for VirtualBox    | pacchetto<br />  | virtualbox-ose-kmp-pae         | Kernel Module for VirtualBox    | pacchetto<br />  | xorg-x11-driver-virtualbox-ose | VirtualBox X11 drivers for mo-&gt; | pacchetto<br /><br /><br />

La "i" indica i pacchetti installati. Io ne ho solo uno perchè ho installato la versione scaricata da internet. Tu cosa hai?
Devi avere almeno virtualbox-ose e un modulo virtualbox-ose-kmp-? in base al tuo kernel. Prova a controllare.
Ciao.