Virtualbox

42 risposte [Ultimo messaggio]
Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Difficile a dirsi con cosi` poche informazioni. Magari il kernel source non installato.
Guarda dentro il file /var/log/vbox-install.log per avere piu` informazioni

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di Crismon
Crismon
(Guru)
Offline
Guru
Iscritto: 28/11/2006
Messaggi: 1715

Questo è quanto dice il file [b]/var/log/vbox-install.log[b]

make KBUILD_VERBOSE=1 -C /lib/modules/2.6.22.12-0.1-default/build SUBDIRS=/tmp/vbox.9 SRCROOT=/tmp/vbox.9 modules<br />make[1]: Entering directory `/usr/src/linux-2.6.22.12-0.1-obj/i386/default&#039;<br />make -C ../../../linux-2.6.22.12-0.1 O=../linux-2.6.22.12-0.1-obj/i386/default modules<br />make -C /usr/src/linux-2.6.22.12-0.1-obj/i386/default \<br />  KBUILD_SRC=/usr/src/linux-2.6.22.12-0.1 \<br /> KBUILD_EXTMOD=&quot;/tmp/vbox.9&quot; -f /usr/src/linux-2.6.22.12-0.1/Makefile modules<br />/usr/src/linux-2.6.22.12-0.1/scripts/gcc-version.sh: line 11: gcc: command not found<br />/usr/src/linux-2.6.22.12-0.1/scripts/gcc-version.sh: line 12: gcc: command not found<br />make[3]: gcc: Command not found<br />test -e include/linux/autoconf.h -a -e include/config/auto.conf || (               \<br /> echo;                                                           \<br /> echo &quot;  ERROR: Kernel configuration is invalid.&quot;;             \<br /> echo &quot;         include/linux/autoconf.h or include/config/auto.conf are missing.&quot;;    \<br /> echo &quot;         Run &#039;make oldconfig &amp;&amp; make prepare&#039; on kernel src to fix it.&quot;;      \<br /> echo;                                                           \<br /> /bin/false)<br />mkdir -p /tmp/vbox.9/.tmp_versions<br />rm -f /tmp/vbox.9/.tmp_versions/*<br />make -f /usr/src/linux-2.6.22.12-0.1/scripts/Makefile.build obj=/tmp/vbox.9<br />  gcc -Wp,-MD,/tmp/vbox.9/linux/.SUPDrv-linux.o.d  -nostdinc -isystem  -D__KERNEL__ -Iinclude -Iinclude2 -I/usr/src/linux-2.6.22.12-0.1/include -include include/linux/autoconf.h   -I/tmp/vbox.9 -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -Werror-implicit-function-declaration -fno-strict-aliasing -fno-common -Os -pipe -msoft-float -mregparm=3 -freg-struct-return -march=i586 -ffreestanding -maccumulate-outgoing-args -I/usr/src/linux-2.6.22.12-0.1/include/asm-i386/mach-generic -Iinclude/asm-i386/mach-generic -I/usr/src/linux-2.6.22.12-0.1/include/asm-i386/mach-default -Iinclude/asm-i386/mach-default -fomit-frame-pointer  -I/lib/modules/2.6.22.12-0.1-default/build/include  -I/tmp/vbox.9/  -I/tmp/vbox.9/include  -I/tmp/vbox.9/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DCONFIG_VBOXDRV_AS_MISC -DRT_ARCH_X86 -DVBOX_WITHOUT_IDT_PATCHING -DUSE_NEW_OS_INTERFACE_FOR_MM -DMODULE -D&quot;KBUILD_STR(s)=#s&quot; -D&quot;KBUILD_BASENAME=KBUILD_STR(SUPDrv_linux)&quot;  -D&quot;KBUILD_MODNAME=KBUILD_STR(vboxdrv)&quot; -c -o /tmp/vbox.9/linux/.tmp_SUPDrv-linux.o /tmp/vbox.9/linux/SUPDrv-linux.c<br />/bin/sh: gcc: command not found<br />make[4]: *** [/tmp/vbox.9/linux/SUPDrv-linux.o] Error 127<br />make[3]: *** [_module_/tmp/vbox.9] Error 2<br />make[2]: *** [modules] Error 2<br />make[1]: *** [modules] Error 2<br />make[1]: Leaving directory `/usr/src/linux-2.6.22.12-0.1-obj/i386/default&#039;<br />make: *** [vboxdrv] Error 2

www.crismonblog.org | Un blog targato openSUSE

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Quote:

Crismon ha scritto:
Questo è quanto dice il file /var/log/vbox-install.log[b]

make KBUILD_VERBOSE=1 -C /lib/modules/2.6.22.12-0.1-default/build SUBDIRS=/tmp/vbox.9 SRCROOT=/tmp/vbox.9 modules<br />make[1]: Entering directory `/usr/src/linux-2.6.22.12-0.1-obj/i386/default&#039;<br />make -C ../../../linux-2.6.22.12-0.1 O=../linux-2.6.22.12-0.1-obj/i386/default modules<br />make -C /usr/src/linux-2.6.22.12-0.1-obj/i386/default \<br />  KBUILD_SRC=/usr/src/linux-2.6.22.12-0.1 \<br /> KBUILD_EXTMOD=&quot;/tmp/vbox.9&quot; -f /usr/src/linux-2.6.22.12-0.1/Makefile modules<br />[b]<i>/usr/src/linux-2.6.22.12-0.1/scripts/gcc-version.sh: line 11: gcc: command not found</i></b><br /><b><i>/usr/src/linux-2.6.22.12-0.1/scripts/gcc-version.sh: line 12: gcc: command not found</i></b><br /><b><i>make[3]: gcc: Command not found</i></b><br />...<br /><b><i>/bin/sh: gcc: command not found</i></b><br />make[4]: *** [/tmp/vbox.9/linux/SUPDrv-linux.o] Error 127<br />make[3]: *** [_module_/tmp/vbox.9] Error 2<br />make[2]: *** [modules] Error 2<br />make[1]: *** [modules] Error 2<br />make[1]: Leaving directory `/usr/src/linux-2.6.22.12-0.1-obj/i386/default&#039;<br />make: *** [vboxdrv] Error 2

(Re)installa il gcc, non viene trovato.

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di Crismon
Crismon
(Guru)
Offline
Guru
Iscritto: 28/11/2006
Messaggi: 1715

Perfetto grande Orion...sempre infallibile.

linux-v7jl:/home/enrico # /etc/init.d/vboxdrv setup<br />Stopping VirtualBox kernel module                                    done<br />Recompiling VirtualBox kernel module                                 done<br />Starting VirtualBox kernel module                                    done

Grazie 1000!!!

www.crismonblog.org | Un blog targato openSUSE

Ritratto di pask3
pask3
(Junior)
Offline
Junior
Iscritto: 11/11/2007
Messaggi: 17

Buon giorno.
Uso openSUSE 10.3 è ho installato con YaST "VirtualBox 1.5.0_OSE".

Quando faccio partire virtualbox mi comare l errore:

"
VirtualBox kernel driver not installed. The vboxdrv kernel module was either not loaded or /dev/vboxdrv was not created for some reason. Re-setup the kernel module by executing '/etc/init.d/vboxdrv setup' as root.
VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED).

Result Code:
0x80004005
Component:
Console
Interface:
IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}
"
Ho provato di tutto ma non riesco a risolvere il problema.
Qualcuno mi potrebbe aiutare?
Grazie!
ciao a tutti.

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Hai installato il gcc? Hai installato il kernel-source? Hai aggiunto il tuo utente al gruppo vboxusers? Se no, aggiungiti da yast e riavvia il pc.
Dopo aver installato gcc e kernel-source (c'e` una guida che spiega come farlo), dai il comando (come root) /etc/init.d/vboxdrv setup e guarda se termina senza darti errori.
Nel caso, postali.

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di Alfio
Alfio
(Guru)
Offline
Guru
Iscritto: 30/08/2005
Messaggi: 2678

Quote:

pask3 ha scritto:
Buon giorno.
Uso openSUSE 10.3 è ho installato con YaST "VirtualBox 1.5.0_OSE".

Quando faccio partire virtualbox mi comare l errore:

"
VirtualBox kernel driver not installed. The vboxdrv kernel module was either not loaded or /dev/vboxdrv was not created for some reason. Re-setup the kernel module by executing '/etc/init.d/vboxdrv setup' as root.
VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED).

Result Code:
0x80004005
Component:
Console
Interface:
IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}
"
Ho provato di tutto ma non riesco a risolvere il problema.
Qualcuno mi potrebbe aiutare?
Grazie!
ciao a tutti.

Perchè non installi la versione rpm dal sito ufficiale che è più semplice da installare?
http://www.virtualbox.org/wiki/Downloads
Senza lasciare il consiglio di orion vanno installate lo stesso i compilatori.
Ciao Big Grin

Ritratto di pask3
pask3
(Junior)
Offline
Junior
Iscritto: 11/11/2007
Messaggi: 17

Grazie dei consigli!
Ho installato quello del sito ufficiale.
E sembra ke funzioni tutto alla grande!
Grazie mille a tutti!
E... complimenti x il sito!
Veramente utile!
ciao ciao Big Grin

Ritratto di doc_pluto
doc_pluto
(Guru)
Offline
Guru
Iscritto: 08/02/2007
Messaggi: 871

questa discussione mi è stata molto utile..

solo una cosa..

ho creato una macchina virtuale vuota ed attivato l'utilizzo del cdrom ed del floppy.. avviando la macchina e selezionando il boot da cd, non riesce ad accedervi..

se invece seleziono al posto di un cd, un'immagine iso, viene caricata..

Hardware: MB:P5E3_Deluxe - CPU:Core2Duo E8400 3.0GHz - RAM:Kingstone_2Gb_DDR3 - Video:GeForce9600GT/PCI/SSE2 - HD: 2x WDCaviarBlue 1TB
--------------------------------
Software: SO:openSuSE 12.1 - ARCH:64bit - DE:Gnome3 - DriverVideo:Ufficiali Nvidia

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

A me parte tranquillamente da cdrom. Prova a controllare che esista il link simbolico /dev/cdrom che punta al tuo lettore cd (dovrebbe essere /dev/sr0)

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde