xpm

18 risposte [Ultimo messaggio]
Ritratto di fioccobianco
fioccobianco
(Geek)
Offline
Geek
Iscritto: 04/10/2007
Messaggi: 112

devo installare un programma da sorgente. tutto liscio fino a quando dopo aver scritto ./configure mi chiede
X11-devel io ne ho trovato una versione rpm
però nell'install del programma originario mi diveca
If you are using some Unix, you need to have libXpm installed. On very few systems libXpm.a is not available. In that case get the pre-built version from:

ftp://root.cern.ch/root/xpm

Then use either environment variable XPM or "configure" flags "--with-xpm=<dir>" to specify where you installed libXpm, if you didn't install it in some generally searched directory (see more below).
e ho anche questo pacchetto
ma come apro un xpm ?
devo semplicemente muoverlo nella cartella in cui voglio installare il programma ed eseguo i comandi ./configure?
o devo installare rpm da root?
grazie

Ritratto di auris
auris
(Guru)
Offline
Guru
Iscritto: 10/09/2004
Messaggi: 4923

Perchè apri post su post inerenti l'installazione del programma root?
http://download.opensuse.org/distribution/10.3/repo/oss/suse/i586/xorg-x11-libXpm-7.2-65.i586.rpm
http://download.opensuse.org/distribution/10.3/repo/oss/suse/i586/xorg-x11-libXpm-devel-7.2-65.i586.rpm

Se sei stanco di virus e schermate blu passa a Linux

Ritratto di fioccobianco
fioccobianco
(Geek)
Offline
Geek
Iscritto: 04/10/2007
Messaggi: 112

ma devo scaricare i file che mi hai dato con rpm?
grazie

Ritratto di auris
auris
(Guru)
Offline
Guru
Iscritto: 10/09/2004
Messaggi: 4923

O li installi con YAST dal CD/DVD.

Se sei stanco di virus e schermate blu passa a Linux

Ritratto di ferdybassi
ferdybassi
(Guru)
Offline
Guru
Iscritto: 11/09/2005
Messaggi: 2668

Ascolta, te l'ho già scritto in uno dei mille post aperti.
Configurati i repository e impara a usarli.
E' una cosa che va fatta PRIMA di incominciare a installare programmi, dato che i repository servono appunto a facilitare la ricerca e l'installazione dei programmi.
I link alle guide su come usare i repository li trovi nella mia risposta.
Ciao ciao

Amministratore di
www.it-opensuse.org

Ritratto di fioccobianco
fioccobianco
(Geek)
Offline
Geek
Iscritto: 04/10/2007
Messaggi: 112

1)nei repository non c'e' root_v5
2)mi serve per lavoro
3)con yast non trovo la libreria che cerco
4)in opensorce ci sono le librerie ma per dipendenze varie continuo a doverne scaricare fino a quando poi arrivo ad un punto che non posso continuare
5)nei repository non c'e la librearia che cerco
6)se non si riesce o non riouscite ditemelo che non perdiamo tempo
grazie

Ritratto di ferdybassi
ferdybassi
(Guru)
Offline
Guru
Iscritto: 11/09/2005
Messaggi: 2668

Quote:

auris ha scritto:
Perchè apri post su post inerenti l'installazione del programma root?
http://download.opensuse.org/distribution/10.3/repo/oss/suse/i586/xorg-x11-libXpm-7.2-65.i586.rpm
http://download.opensuse.org/distribution/10.3/repo/oss/suse/i586/xorg-x11-libXpm-devel-7.2-65.i586.rpm

Come non c'è la libreria che cerchi??
E quelle qui sopra che ti ha indicato auris, presenti nel REPOSITORY UFFICIALE di SUSE che cosa sono, noccioline???
Se ti dico di imparare cosa sono i repository e come configurarli è perchè:
1) vedo che nei repository c'è quello che cerchi
2) deduco che, se non trovi, li usi male

Magari non ci sarà root, ma almeno ci sono tutte le librerie che richiede. E installarle dai repository SEMPLIFICHERA' enormemente l'installazione successiva di root.
Detto questo, li hai configurati o no 'sti belin di repository??
Ti chiedo questo perchè dalle domande che fai:
Quote:

fioccobianco ha scritto:
ma devo scaricare i file che mi hai dato con rpm?
grazie

sembra che tu non abbia nemmeno preso in considerazione l'idea di imparare come funziona l'installazione del software in SUSE...
Se è così, come dici tu, faccelo sapere che non perdiamo tempo...

Ciao ciao

Amministratore di
www.it-opensuse.org

Ritratto di fioccobianco
fioccobianco
(Geek)
Offline
Geek
Iscritto: 04/10/2007
Messaggi: 112

mi scuso ma mi stavo innervosendo.
ho installato tutto
ho fatto ./configure
make
make install/ su root)
e come mai quando lancio l'applicazione non parte?
cioè se nel xterm scrivo il nome mi dice command non valid
perchè?grazie
ciao

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Il comando make ha terminato correttamente o ha riportato errori?
su lo ha fatto prima o dopo il make install?

Il messaggio esatto e` "command not valid" o "command not found"?

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di fioccobianco
fioccobianco
(Geek)
Offline
Geek
Iscritto: 04/10/2007
Messaggi: 112

non mi ha dato nessun errore in via di installazione
su l'ho fatto prima di make install
dopo make install
mi ha ridato il prompt
allora ho scritto root(dovrebbe essere comando per chiamare)(mi serve per un esame sul c++)
e mi dice command not found
grazie e mi scuso ancora del mio comportamento, siete gentili a sopportarmi ma ormai sono disperato

Ritratto di fioccobianco
fioccobianco
(Geek)
Offline
Geek
Iscritto: 04/10/2007
Messaggi: 112

cosa posso fare?grazie