YAST non funziona (gestore pacchetti)

14 risposte [Ultimo messaggio]
Ritratto di TuxSoul
TuxSoul
(Junior)
Offline
Junior
Iscritto: 04/09/2007
Messaggi: 31

Salve.
Premetto che avevo provato a installare l'rmp di VirtualBox ma non ci sono riuscito per via di delle dipendenze.
Ho provato ad aprire il gestore pacchetti di Yast ma dopo che aggiorna tutte le fonti (o qualsiasi cosa faccia) anzichè spuntare quella bella schermata con il selettore pacchetti spunta un messaggio di errore:
VirtualBox non è presente sul supporto.
E Yast sparisce.
Che devo fare? Aiutatemi perfavore!

Sistema corrente: OpenSUSE 11.4, GNOME @ Acer Aspire 5553G { AMD Phenom II X4 N930 @ 2GHz, 4GB DDR3 1033Mhz, ATI Mobility Radeon HD5650 1GB }

Ritratto di TuxSoul
TuxSoul
(Junior)
Offline
Junior
Iscritto: 04/09/2007
Messaggi: 31

All'inizio avevo provato a installare VirtualBox con KPackage.

Ora ho provato a installarlo con YAST ma mi da sempre lo stesso errore. Aiutatemi!

Sistema corrente: OpenSUSE 11.4, GNOME @ Acer Aspire 5553G { AMD Phenom II X4 N930 @ 2GHz, 4GB DDR3 1033Mhz, ATI Mobility Radeon HD5650 1GB }

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Apri una shell testuale, dai il comando su per diventare root, poi dai il comando rpm -ivh VirtualBox*.rpm (dopo esserti spostato nella directory che contiene l'rpm). Se ti dice che mancano delle dipendenze, via Yast le installi e poi riprovi ad installare virtualbox.

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di TuxSoul
TuxSoul
(Junior)
Offline
Junior
Iscritto: 04/09/2007
Messaggi: 31

error: Failed dependencies:<br />        libxalan-c.so.110()(64bit) is needed by VirtualBox-1.5.0_24069_openSUSE102-2.x86_64<br />        libxerces-c.so.27()(64bit) is needed by VirtualBox-1.5.0_24069_openSUSE102-2.x86_64
Questo è quel che da...

Il problema è proprio che non posso installare ne aprire il gestore pacchetti Yast perchè mi da:
VirtualBox non è presente nel supporto.

Anche se provo semplicemente ad aprire il gestore pacchetti.
E' proprio questo il mio problema ... Sad

Sistema corrente: OpenSUSE 11.4, GNOME @ Acer Aspire 5553G { AMD Phenom II X4 N930 @ 2GHz, 4GB DDR3 1033Mhz, ATI Mobility Radeon HD5650 1GB }

Ritratto di TuxSoul
TuxSoul
(Junior)
Offline
Junior
Iscritto: 04/09/2007
Messaggi: 31

Dimenticavo, è tutta la mattinata che cerco queste librerie ma non le trovo. Se le trovassi potrei continuare l'installazione con KPackage e Yast dovrebbe tornare a funzionare... Il problema è trovarle... Sad

Sistema corrente: OpenSUSE 11.4, GNOME @ Acer Aspire 5553G { AMD Phenom II X4 N930 @ 2GHz, 4GB DDR3 1033Mhz, ATI Mobility Radeon HD5650 1GB }

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Scusa, ma se dai il comando yast2 sw_single dopo essere diventato root con il comando su, non ti si apre il gestore dei pacchetti?
(e i pacchetti da installare sono xalan e xercer, non libxalan e libxerces)

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di TuxSoul
TuxSoul
(Junior)
Offline
Junior
Iscritto: 04/09/2007
Messaggi: 31

Sto provando...
P.S.: ma è normale che ogni volta che avvio Yast se non killo zypper da root mi da sempre che un'altra applicazione sta usando il database dei pacchetti?

Sistema corrente: OpenSUSE 11.4, GNOME @ Acer Aspire 5553G { AMD Phenom II X4 N930 @ 2GHz, 4GB DDR3 1033Mhz, ATI Mobility Radeon HD5650 1GB }

Ritratto di TuxSoul
TuxSoul
(Junior)
Offline
Junior
Iscritto: 04/09/2007
Messaggi: 31

Ok funziona Big Grin

Sistema corrente: OpenSUSE 11.4, GNOME @ Acer Aspire 5553G { AMD Phenom II X4 N930 @ 2GHz, 4GB DDR3 1033Mhz, ATI Mobility Radeon HD5650 1GB }

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Quote:

TuxSoul ha scritto:
Sto provando...
P.S.: ma è normale che ogni volta che avvio Yast se non killo zypper da root mi da sempre che un'altra applicazione sta usando il database dei pacchetti?

Si`. Io lo ho disinstallato, onde evitare che si avvii. La prossima volta, invece di killarlo, prova a fermare il servizio con il comando rczypper stop oppure rczmd stop (non mi ricordo di preciso quale sia).

Funziona. Cosa? VirtualBox o Yast?

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di TuxSoul
TuxSoul
(Junior)
Offline
Junior
Iscritto: 04/09/2007
Messaggi: 31

Yast e di conzeguenza appena finisco di installare le dipendenze anche VirtualBox... C'è un piccolo problema ... Praticamente il dvd è disperso tra il miliardo di dvd a casa mia... Ora mi cerca il dvd per installare dei pacchetti... Non c'è un modo per faglieli installare da internet? Avevo sentito dire di cd che si installavano dalla rete. Posso usare quel server? Se si, qual'è l'indirizzo?

Comunque grazie di tutto Laughing
Senza voi ero spacciato :-P

Sistema corrente: OpenSUSE 11.4, GNOME @ Acer Aspire 5553G { AMD Phenom II X4 N930 @ 2GHz, 4GB DDR3 1033Mhz, ATI Mobility Radeon HD5650 1GB }

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Puoi sostituire il dvd con i repository ufficiali, che trovi in questa pagina, oppure usando uno dei tanti mirror disponibili.

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde