Blocchi vari

11 risposte [Ultimo messaggio]
Ritratto di Zar Marco
Zar Marco
(Geek)
Offline
Geek
Iscritto: 22/02/2016
Messaggi: 85

Ciao ragazzi, scrivo qui perché non so dove altro mettere.
In pratica, ogni volta che provo a riavviare o sconnettere in mio utente, il laptop si blocca e devo andare ad agire sul tasto di spegnimento in maniera forzata. Dove potrei andare a ricercare il motivo di tale comportamento?
Come driver video ho i nouveau

Lenovo Legion Y520 i7 7700HQ 8 Gb ram openSUSE Tumbleweed KDE/Arch KDE/i3

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 879

Installa hwinfo > sudo zypper in hwinfo
Poi > sudo hwinfo --gfxcard
Cosi vediamo che driver stai utilizzando .

Ritratto di Zar Marco
Zar Marco
(Geek)
Offline
Geek
Iscritto: 22/02/2016
Messaggi: 85

Ecco qui,

saul@legion_of_chameleon ~                                                   [16:28:46] 
> $ sudo hwinfo --gfxcard                                                              
[sudo] password di root: 
11: PCI 02.0: 0300 VGA compatible controller (VGA)              
  [Created at pci.378]
  Unique ID: _Znp.OALzO4CmJc6
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "Intel VGA compatible controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x591b 
  SubVendor: pci 0x17aa "Lenovo"
  SubDevice: pci 0x39d1 
  Revision: 0x04
  Driver: "i915"
  Driver Modules: "i915"
  Memory Range: 0xa2000000-0xa2ffffff (rw,non-prefetchable)
  Memory Range: 0xb0000000-0xbfffffff (ro,non-prefetchable)
  I/O Ports: 0x6000-0x603f (rw)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 128 (42422 events)
  Module Alias: "pci:v00008086d0000591Bsv000017AAsd000039D1bc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
 
24: PCI 100.0: 0302 3D controller
  [Created at pci.378]
  Unique ID: VCu0.i3AKd43+Qx2
  Parent ID: vSkL.G5s_S6UiSZ8
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "nVidia GP107M [GeForce GTX 1050 Mobile]"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x1c8d "GP107M [GeForce GTX 1050 Mobile]"
  SubVendor: pci 0x17aa "Lenovo"
  SubDevice: pci 0x39d1 
  Revision: 0xa1
  Driver: "nouveau"
  Driver Modules: "nouveau"
  Memory Range: 0xa3000000-0xa3ffffff (rw,non-prefetchable)
  Memory Range: 0x90000000-0x9fffffff (ro,non-prefetchable)
  Memory Range: 0xa0000000-0xa1ffffff (ro,non-prefetchable)
  I/O Ports: 0x5000-0x5fff (rw)
  IRQ: 129 (24 events)
  Module Alias: "pci:v000010DEd00001C8Dsv000017AAsd000039D1bc03sc02i00"
  Driver Info #0:
    Driver Status: nouveau is active
    Driver Activation Cmd: "modprobe nouveau"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #21 (PCI bridge)
 
Primary display adapter: #11

ora mi si è bloccato altre tre volte, mentre era in uso. Devo cercare qualche log

Lenovo Legion Y520 i7 7700HQ 8 Gb ram openSUSE Tumbleweed KDE/Arch KDE/i3

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 879

Mi sembra di capire che hai tutte e due i driver attivi , con queste doppie schede devi configurare Bumblebee , oppure dal bios ne escludi una
Io proverei dal bios , anche perchè non mi è mai capitato di avere a che fare con Bumblebee

Ritratto di Zar Marco
Zar Marco
(Geek)
Offline
Geek
Iscritto: 22/02/2016
Messaggi: 85

Ma disattivando l'integrata poi dovrò andare a disinstallare il secondo driver?

Lenovo Legion Y520 i7 7700HQ 8 Gb ram openSUSE Tumbleweed KDE/Arch KDE/i3

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 879

No se guardi tra i driver troverai anche amdgpu installati
Su un portataile io disabiliterei l' Nvidia , puoi sempre provarle entrambe

Ritratto di Zar Marco
Zar Marco
(Geek)
Offline
Geek
Iscritto: 22/02/2016
Messaggi: 85

Andrò a disattivare l'Intel, la Nvidia sarà utile per utilizzare Blender.
Grazie mille per l'aiuto!

Lenovo Legion Y520 i7 7700HQ 8 Gb ram openSUSE Tumbleweed KDE/Arch KDE/i3

Ritratto di Zar Marco
Zar Marco
(Geek)
Offline
Geek
Iscritto: 22/02/2016
Messaggi: 85

Ciao, allora, ho scoperto di non poter disattivare l'integrata, quindi causa utilizzo di blender per ora rimango così. Ho fatto la ricerca per sapere se ho amdgpu installata, ma non è così. E' meglio se lo installo?

Lenovo Legion Y520 i7 7700HQ 8 Gb ram openSUSE Tumbleweed KDE/Arch KDE/i3

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 879

Devi configurare Bumblebee .

Ritratto di Zar Marco
Zar Marco
(Geek)
Offline
Geek
Iscritto: 22/02/2016
Messaggi: 85

Per ora non si blocca più, non posso mettere risolto perché così non è. Proverò comunque ad abilitare bumblebee

Lenovo Legion Y520 i7 7700HQ 8 Gb ram openSUSE Tumbleweed KDE/Arch KDE/i3

Ritratto di CarloCC
CarloCC
(Monster)
Offline
Monster
Iscritto: 06/04/2017
Messaggi: 281

Puoi anche provare se si riesce a controllare qual'è il processo che blocca il pc magari dal monitor di sistema.

Acer Aspire E1-522 Amd Quad-Core E2-3800--Amd Radeon 8280
Acer Aspire M5500 Intel Quad-Core - Amd Radeon R5 230
Distribuzione openSUSE Leap 15 Kde Plasma5 - Tumbleweed