errore durante agg. a rc1dopo corrente saltata

8 risposte [Ultimo messaggio]
Ritratto di Riccardo1986
Riccardo1986
(Monster)
Offline
Monster
Iscritto: 27/10/2007
Messaggi: 302

ciao ragazzi ieri stavo aggiornando suse 10.3 ad rc1 tramite network ed e saltata la corrente ed ora stò provando a riprendere l'agg. ma ricevo un errore su ogni apcchetto installato: "subprocess failed. error: rpm non riuscito......."
si può fare qualcosa o devo reinstallare da zero???

I5660 P7P55D PRO GTX 560TI 4GB DDR3 PINNACLE 300i ASUS VENTO

Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

va su "dettagli" e posta l'errore completo per favore

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el

Ritratto di Riccardo1986
Riccardo1986
(Monster)
Offline
Monster
Iscritto: 27/10/2007
Messaggi: 302

subprocess failed. error: rpm non riuscito error: d4b error(-30987) from dbcursor -> c_get DB_PAGE_NOTFOUND

e poi aggiunge molte righe con los tesso errore sostanzialmente

I5660 P7P55D PRO GTX 560TI 4GB DDR3 PINNACLE 300i ASUS VENTO

Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

è zompato il database rpm o di zypper... mi sa che ti sbrighi prima a rifarla... altrimenti puoi provare a ricreare i database

ctrl+alt+f3 per entrare in shell di admin

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el

Ritratto di Riccardo1986
Riccardo1986
(Monster)
Offline
Monster
Iscritto: 27/10/2007
Messaggi: 302

provo xkè questo portatile ha un sacco di configurazioni e rifarle è piuttosto dispendioso, scusami solo una cosa ma ctrl+alt+f3 lo devo dare quando ricevo l'errore???e per ricreare il database "rpm --rebuilddb giusto???
grazie

I5660 P7P55D PRO GTX 560TI 4GB DDR3 PINNACLE 300i ASUS VENTO

Ritratto di Riccardo1986
Riccardo1986
(Monster)
Offline
Monster
Iscritto: 27/10/2007
Messaggi: 302

sapresti dirmi cosa digitare di preciso?xkè lì ho la shell, ma se digito nn fà nulla....

I5660 P7P55D PRO GTX 560TI 4GB DDR3 PINNACLE 300i ASUS VENTO

Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

per il database rpm è si quello... per zypper invece:

1) rm /var/cache/zypp/zypp.db
2) zypper refresh

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el

Ritratto di Riccardo1986
Riccardo1986
(Monster)
Offline
Monster
Iscritto: 27/10/2007
Messaggi: 302

ok grazie, ancora una cosa mi è poco chiara, quando lo devo fare? xkè il sistema nn me lo lascia avviare.....ed è possibile farlo quando dà l'errore nell'aggiornamento?
grazie

I5660 P7P55D PRO GTX 560TI 4GB DDR3 PINNACLE 300i ASUS VENTO

Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

prima di avviare l'installazione degli rpm stessi

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el