esecuzione comando avvio

4 risposte [Ultimo messaggio]
Ritratto di croweland
croweland
(Geek)
Offline
Geek
Iscritto: 26/06/2005
Messaggi: 66

Buongiorno a tutti,
ho da poco installato Leap 15.1 versione gnome su un notebook.
tutto ok sto procedendo alle varie configurazioni.
devo eseguire all'avvio questo comando per poter montare OneDrive:

sh -c "rclone --vfs-cache-mode writes mount onedrive: ~/OneDrive"

su ubuntu c'e' la possibilita' di inserirlo trami programma esecuzione avvio, qui su suse non riesco a trovarlo e non so proprio come poter fare.
potete aiutarmi per favore?
grazie e a presto

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2724

http://www.suseitalia.org/forum/generale/eseguire-comandi-allavvio?page=1

SUSE Tumbleweed- kernel-5.1.7-1.2- kde-plasma-5.16.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di croweland
croweland
(Geek)
Offline
Geek
Iscritto: 26/06/2005
Messaggi: 66

ho un file 1onedrive.sh
sh -c "rclone --vfs-cache-mode writes mount onedrive: ~/OneDrive"
exit 0

messo in etc/init.d
e all'interno di /etc/init.d/fc0.d

e comunque non va all'avvio.

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 878

Prova a vedere quà https://forums.opensuse.org/showthread.php/534591-how-to-start-bash-script-application-on-boot-in-Opensuse-Leap-15
Con Kde lo puoi fare direttamente dalle impostazioni di sistema

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2724

Ho postato il tuo problema sul forum inglese,mi dicono che se hai il file system BTRFS,non funziona devi mettere fs ext4,e riprovare.
ciao

SUSE Tumbleweed- kernel-5.1.7-1.2- kde-plasma-5.16.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/