Grub e OpenSuse

6 risposte [Ultimo messaggio]
Ritratto di Andrew85
Andrew85
(Newbie)
Offline
Newbie
Iscritto: 11/03/2016
Messaggi: 3

Salve a tutti,
sono nuovo nel forum (e con l'occasione saluto tutti). Ho un notebook con installato in dualboot ubuntu e OpenSuse. Da principio le versioni dei sistemi erano Ubuntu 14.10 e OpenSuse 42.1. Ho inizialmente installato Ubuntu quindi poi aggiunto OpenSuse (sda3). In seguito però ho fatto l'aggiornamento di Ubuntu portandolo alla versione 15.10 e a seguito di tale aggiornamento dal grub mi è scomparso Suse. Ho provato con tool del tipo grub-customizer ma senza molto successo.
Secondo voi come faccio a ripristinare il grub in modo tale da avere disponibile OpenSuse?
Grazie e ciao

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2729

Entra nel bios e metti come partenza la partizione di suse,una volta fatto il riavvio ti dovrebbe partire suse da li vai di yast e ricrei il boot.é la via piu semplice imho sewmpre se comandava suse il boot se no da ubunto da shell :sudo update-grub
altrimenti segui questa guida:
http://www.lffl.org/2011/11/ripristinare-il-boot-di-ubuntu-dopo.html
ciao

SUSE Tumbleweed- kernel-5.3.11-1.2- kde-plasma-5.17.3.1- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.132.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di Andrew85
Andrew85
(Newbie)
Offline
Newbie
Iscritto: 11/03/2016
Messaggi: 3

Ciao
grazie per la risposta. Allora per quanto riguarda il bios...nulla da fare. Mi dà come scelte di avvio solo l'hd, la nic usb ecc. Non mi lascia scegliere le partizioni. Per quanto riguarda la guida l'ho seguita e quello che sono riuscito ad ottenere è che ora al boot ho come scelta anche opensuse ma selezionandolo mi da error: file "boot/vmlinuz-4.1.15.8-default" non trovato. è necessario caricare il kernel prima.
Deduco che il problema possa essere il kernel a questo punto...

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2729

quindi parte ma non la grafica per il problema del kernel? allora per abilitare il kernel nuovo devi aprire una shell e come root dai incolla questo comando:
grub2-mkconfig -o /boot/grub2/grub.cfg
riavvio
ciao Wink
PS: il -o è una lettera e non un zero.

SUSE Tumbleweed- kernel-5.3.11-1.2- kde-plasma-5.17.3.1- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.132.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di Andrew85
Andrew85
(Newbie)
Offline
Newbie
Iscritto: 11/03/2016
Messaggi: 3

No in realtà non parte, quel messaggio di errore me lo dà dal boot. Subito sotto mi dice di preme un pulsante per continuare e quindi tornando alla schermata precedente posso selezionare un altro os. Pensi possa dare grub2-mkconfig da ubuntu?

update: ok risolto seguendo questa guida http://trucchisuse.altervista.org/blog/ripristinare-grub-ovvero-lavvio-di-suse/ sostanzialmente dovevo ripristinare il grub2 dal disco di installazione. Ora Tutto ok.
Grazie per il sostegno.
A.

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2729

no da ubunto,ti appare la schermata grafica di suse dove ci sono le scelte dei due sistemi

SUSE Tumbleweed- kernel-5.3.11-1.2- kde-plasma-5.17.3.1- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.132.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2729

Bene metti risolto.

SUSE Tumbleweed- kernel-5.3.11-1.2- kde-plasma-5.17.3.1- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.132.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/