opensuse updater, non installa aggiornamenti

4 risposte [Ultimo messaggio]
Ritratto di latulipenoire
latulipenoire
(Junior)
Offline
Junior
Iscritto: 24/04/2009
Messaggi: 9

Salve a tutti Smile premetto che uso da pochissimo tempo opensuse versione 11.0 e quindi sono abbastanza ignorante su molte delle sue funzioni...ma quando s'avvia opensuse updater e mi dice di installare i 12 aggiornamenti che ha selezionato e io seguo tutta la procedura ovvero : installa 12 aggiornamenti-inserisci password-ok , in realtà non li installa e subito dopo ricompare l'icona del triangolo rosso con punto esclamativo. Spero che qualcuno mi saprà spiegare come posso fare a risolvere questo problema Smile

Non c'è nulla che non valga la pena di sapere

Ritratto di AL9000
AL9000
(Guru)
Offline
Guru
Iscritto: 29/10/2005
Messaggi: 1277

senti, lo sai che c'è? che io non sono proprio contento di come agisce l'applet degli update, anche se non riscontro il tuo problema.

Infatti tra le migliorie che vorrei per suse 11.2 ho inserito anche quest'applet.

Non mi piace che certe volte s'impappina, nonostante che io usi il backend zypp (e così a volte dovevo fare gli aggiornamenti a mano con zypper o con yast); non mi piace che non mi indica da quali repositories installa i programmi di cui mi segnala la presenza di una nuova versione; non mi piace che faccia tutto in background, senza darti la possibilità di verificare a che punto è arrivato l'aggiornamento, ecc..

Così uso l'applet solo come "notificatore": quando mi dice che ci sono degli aggiornamenti disponibili, uso zypper per vedere cosa sono, da che repo li installerebbe, ecc. e poi decido se aggiornare o meno (ed eventualmente cosa aggiornare e cosa no), vedendo nel terminale come procede il tutto.

Per le operazioni "automatiche" (cioè quasi senza interazione da parte dell'utente, apparte la psw di root e la conferma dell'installazione) ho realizzato uno scriptino collegato ad un icona, che tramite kdialog mi mostra una finestra con delle opzioni ed io eseguo quella che più mi aggrada a seconda delle esigenze (ogni opzione fa partire un altro script che esegue l'operazione in un terminale con zypper).

Per le operazioni non automatiche (con selezione dei singoli pacchetti o altri casi simili) utilizzo yast o zypper da terminale.

Spero che migliorino le funzionalità di questo updater, perchè così com'è mostra il fianco a diverse critiche.

Ciao

Chi è investito di un'autorità si trasformerà inevitabilmente, secondo una legge sociale immutabile, in un oppressore ed in uno sfruttatore della società. (M.A. Bakunin)

Ritratto di latulipenoire
latulipenoire
(Junior)
Offline
Junior
Iscritto: 24/04/2009
Messaggi: 9

ahimè ho capito ben poco di quello che hai scritto XD purtroppo so ben poche cose su linux e tutti questi passaggi...proverò a usare anche io il tuo sistema...cmq questa cosa degli aggiornamenti è davvero odiosa Sad

Non c'è nulla che non valga la pena di sapere

Ritratto di Murdock
Murdock
(Guru)
Offline
Guru
Iscritto: 06/10/2004
Messaggi: 573

hai un problema di dipendenze...

aggiorna da yast e sei a posto

Murdock - There's no place like /home
openSUSE Leap 42.2 64bit - Plasma 5

Ritratto di latulipenoire
latulipenoire
(Junior)
Offline
Junior
Iscritto: 24/04/2009
Messaggi: 9

infatti...alla fine ci ho pensato anche io di aggiornare da lì e ho risolto il problema Wink

Non c'è nulla che non valga la pena di sapere