Problemi vari dopo aggiornamento

7 risposte [Ultimo messaggio]
Ritratto di rocking_horse
rocking_horse
(Geek)
Offline
Geek
Iscritto: 21/07/2006
Messaggi: 167

Ciao!

Dopo che ho fatto un aggiornamento del kernel presumo, ora ho diversi problemi:

- grub2 è in bianco e nero invece che con la veste grafica OpenSuse
- all'avvio mi chiede il login da riga di comando e per far partire la shell di kde devo digitare startx da riga di comando (meno male che ne so un minimo perché se no non avviavo nemmeno)
- Amarok non riproduce nessun suono, mentre per esempio Vlc funziona.
- l'applicazione per usare il bluetooth non si trova più nell'elenco delle applicazioni.
- inoltre la lingua di Firefox e di openSuse è inglese, pur avendo selezionato italiano.

Questi sono i problemi più evidenti.

openSuse Leap 42.2 - Packard Bell Imedia S Core i3 4 GB RAM - AMD Radeon HD 7350 1GB

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 385

Ciao.

Dovresti specificare il release di openSuSE (42.2?) e quella del kernel.

gigi

Ritratto di rocking_horse
rocking_horse
(Geek)
Offline
Geek
Iscritto: 21/07/2006
Messaggi: 167

ecco qua:

openSuse Leap 42.2 - Packard Bell Imedia S Core i3 4 GB RAM - AMD Radeon HD 7350 1GB

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 385

Release di openSuse e kernel sono identici a quelli che ho installati anch'io senza problemi (diversamente da te ho una CPU AMD).

Se, come sembra, sei in grado di lanciare YaST in modalità grafica puoi provare ad aggiornare tutti i pacchetti di base:

In YaST --> Repository dei programmi lascia abilitati solo i repository ufficiali indispensabili:

openSUSE-Leap-42.2-Oss: http://download.opensuse.org/distribution/leap/42.2/repo/oss/

openSUSE-Leap-42.2-Update: http://download.opensuse.org/update/leap/42.2/oss/

Poi da YaST --> Gestione pacchetti dal Menù principale:

- Opzioni --> Permetti cambio fornitore.

- Pacchetto --> Tutti i pacchetti --> Aggiorna incondizionatamente.

gigi

Ritratto di CarloCC
CarloCC
(Geek)
Offline
Geek
Iscritto: 06/04/2017
Messaggi: 66

Hai abilitato qualche repository...? Anch'io ho Leap 42.2 e non ho alcun problema, ma le prime volte che installavo Opensuse mi capitava che aggiornamenti mi rompevano il sistema, in realtà poi ho scoperto che non utilizzavo correttamente i repository e nemmeno i comandi per aggiornare.
Da quando ho capito come utilizzare correttamente i repository e i comandi di aggiornamento, non ho più avuto problemi di alcun tipo. Ovviamente io non so se sei nuovo in Opensuse oppure un utente navigato, ma su Leap è difficile che si rompa qualcosa.
Utilizzi driver proprietari Nvidia ?
Saluti.

Acer Aspire E1-522 Amd Quad-Core E2-3800--Amd Radeon 8280
Acer Aspire M5500 Intel Core 2 - grafica Nvidia GeForce 315
Distribuzione OpenSuse Leap 42.2 Kde Plasma5 - Tumbleweed

Ritratto di ilgallinetta
ilgallinetta
(Geek)
Offline
Geek
Iscritto: 12/05/2013
Messaggi: 109

Prova a ripristinare l'RPM, chissà che qualcosa non si sistemi. Il comando da terminale è:
sudo rpm -vv --rebuilddb

PC Acer Aspire E1-571 I5 UEFI RAM 8GB.
Windows 10 64 bit
Ubuntu 16.04 LTS
openSUSE 42.3 x86 64 bit KDE5 kernel 4.4.76-1-default

Ritratto di rocking_horse
rocking_horse
(Geek)
Offline
Geek
Iscritto: 21/07/2006
Messaggi: 167

Ho fatto come mi hai detto tu Gi-Gi e ora mi rifunziona tutto a parte Amarok (forse devo reinstallare i codecs?)
Probabilmente avevo attivato per sbaglio dei repository -devel.

Grazie a tutti dei suggerimenti

openSuse Leap 42.2 - Packard Bell Imedia S Core i3 4 GB RAM - AMD Radeon HD 7350 1GB

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2628

rocking_horse ha scritto:

Ho fatto come mi hai detto tu Gi-Gi e ora mi rifunziona tutto a parte Amarok (forse devo reinstallare i codecs?)
Probabilmente avevo attivato per sbaglio dei repository -devel.

Grazie a tutti dei suggerimenti


Quindi si puo mettere risolto

SUSE Tumbleweed- kernel-4.13.1-1.1- kde-plasma-5.10.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-384.59- SSD samsung 850 pro 512 gb http://opensuse-community.org/