Solo a me l'ultima opensuse sembra un disastro ?

Ritratto di Raff82
Raff82
(Geek)
Offline
Geek
Iscritto: 30/03/2011
Messaggi: 151

Io sono un estimatore di KDE/Plasma e con Gnome proprio non vado d'accordo; indubbiamente, all'inizio i crash di Plasma erano piuttosto gravi, ma dopo i primi aggiornamenti la situazione si è risolta e ora la Leap mi appare molto più stabile di OpenSUSE 3.x con KDE4 (che pure è piuttosto solida).
Qualche problema permane ancora; ad esempio, sto usando i repo Mozilla e LibreOffice, i quali però non sembrano sincronizzati con gli altri repo. Il mese scorso mi è arrivata un patch per LibreOffice la quale mi proponeva di cambiare repo (da LibreOffice a Leap-Updates) per installare una versione di LibreOffice (5.4) più vecchia della mia (5.5).
Stesso problema con Firefox; il repo Mozilla sembra meno aggiornato di Leap-Updates per cui ora mi ritrovo con Firefox 44.x nonostante sia già presente l'aggiornamento alla 45.

Ritratto di umby63
umby63
(Junior)
Offline
Junior
Iscritto: 04/03/2016
Messaggi: 10

Grinch ha scritto:

Ormai son su Gnome , ma basta aggiungere questo repo > http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_42.1/ > zypper dup > e va bene anche plasma5 sulla Leap42

MA SCUSA FACENDO COSÌ INCASINI IL SISTEMA, MI HANNO SEMPRE DETTO CHE È MEGLIO AVERE UNA DISTRO CON UN de UNICO E NON DOPPIO....
tu di gnome usi opensuse 13.2?

umby

Ritratto di umby63
umby63
(Junior)
Offline
Junior
Iscritto: 04/03/2016
Messaggi: 10

guardate qsto link
http://www.miamammausalinux.org/2015/07/gnome-e-meglio-di-kde-parola-di-utente/

umby

Ritratto di Arin
Arin
(Junior)
Offline
Junior
Iscritto: 18/11/2009
Messaggi: 44

Per Leap è meglio usare ancora Gnome, anche se kde5 è più bello.
Purtroppo non c'é possibilità di installare kde4. come nella 13.2 è disponibile la vecchia kde3.
Il problema di Linux è quando si riesce a costruire una distribuzione quasi perfetta come la 13.2 , è già da rottamare per il ciclo di vita troppo breve.
Linux è valido per lavorarci nell' ambito server in modalità testuale o al più X-window.
Invece nell'ambito desktop si da troppa importanza al rivoluzionare il sistema operativo, quando invece la scelta vincente nell'ambito desktop sono la qualità delle applicazioni che girano su di esso.

Ritratto di Dr.Slump
Dr.Slump
(Junior)
Offline
Junior
Iscritto: 08/11/2014
Messaggi: 26

mi ha fatto ancora lo scherzo di kmail con la pagina bianca, mi son stracciato i cosidetti... cmq ho settato il repo di KDE 5.5 e ho fatto l'upgrade, sono stato cmq costretto a ripristinare i file di configurazione backuppati per ripristinare l'accesso alla posta.. L'errore quando apro il programma lo fa ancora, anche se con una grafica diversa...

A sto punto pubblico il backtrace se qualcuno ci capisce qualcosa

Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f08e93d6800 (LWP 1627))]
 
Thread 11 (Thread 0x7f08c4b40700 (LWP 1628)):
#0  0x00007f08e63d2bbd in poll () from /lib64/libc.so.6
#1  0x00007f08d988d422 in _xcb_conn_wait () from /usr/lib64/libxcb.so.1
#2  0x00007f08d988f00f in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007f08c686b3c9 in ?? () from /usr/lib64/libQt5XcbQpa.so.5
#4  0x00007f08e6ce232f in ?? () from /usr/lib64/libQt5Core.so.5
#5  0x00007f08dcb6c0a4 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f08e63dafed in clone () from /lib64/libc.so.6
 
Thread 10 (Thread 0x7f08be702700 (LWP 1640)):
#0  0x00007f08e63d2bbd in poll () from /lib64/libc.so.6
#1  0x00007f08dc64fe64 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f08dc64ff7c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f08e6f14d8b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#4  0x00007f08e6ebbd53 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#5  0x00007f08e6cdd61a in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#6  0x00007f08e6ce232f in ?? () from /usr/lib64/libQt5Core.so.5
#7  0x00007f08dcb6c0a4 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f08e63dafed in clone () from /lib64/libc.so.6
 
Thread 9 (Thread 0x7f08a37fe700 (LWP 1668)):
#0  0x00007f08dcb7003f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f08d76e4733 in ?? () from /usr/lib64/libQt5WebKit.so.5
#2  0x00007f08d76e4759 in ?? () from /usr/lib64/libQt5WebKit.so.5
#3  0x00007f08dcb6c0a4 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f08e63dafed in clone () from /lib64/libc.so.6
 
Thread 8 (Thread 0x7f0855cb5700 (LWP 1675)):
#0  0x00007f08dcb7003f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f08d73f075d in ?? () from /usr/lib64/libQt5WebKit.so.5
#2  0x00007f08d7713031 in ?? () from /usr/lib64/libQt5WebKit.so.5
#3  0x00007f08dcb6c0a4 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f08e63dafed in clone () from /lib64/libc.so.6
 
Thread 7 (Thread 0x7f08554b4700 (LWP 1676)):
#0  0x00007f08dcb7003f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f08d73f1733 in ?? () from /usr/lib64/libQt5WebKit.so.5
#2  0x00007f08d7713031 in ?? () from /usr/lib64/libQt5WebKit.so.5
#3  0x00007f08dcb6c0a4 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f08e63dafed in clone () from /lib64/libc.so.6
 
Thread 6 (Thread 0x7f083cd04700 (LWP 2077)):
#0  0x00007f08e63d2bbd in poll () from /lib64/libc.so.6
#1  0x00007f08dc64fe64 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f08dc64ff7c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f08e6f14d8b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#4  0x00007f08e6ebbd53 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#5  0x00007f08e6cdd61a in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#6  0x00007f08e6ce232f in ?? () from /usr/lib64/libQt5Core.so.5
#7  0x00007f08dcb6c0a4 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f08e63dafed in clone () from /lib64/libc.so.6
 
Thread 5 (Thread 0x7f083e947700 (LWP 2079)):
#0  0x00007f08e63cec8d in read () from /lib64/libc.so.6
#1  0x00007f08dc690b60 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f08dc64f999 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f08dc64fdf8 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f08dc64ff7c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f08e6f14d8b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#6  0x00007f08e6ebbd53 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#7  0x00007f08e6cdd61a in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#8  0x00007f08e6ce232f in ?? () from /usr/lib64/libQt5Core.so.5
#9  0x00007f08dcb6c0a4 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f08e63dafed in clone () from /lib64/libc.so.6
 
Thread 4 (Thread 0x7f083f148700 (LWP 2081)):
#0  0x00007f08e63d2bbd in poll () from /lib64/libc.so.6
#1  0x00007f08dc64fe64 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f08dc64ff7c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f08e6f14d8b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#4  0x00007f08e6ebbd53 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#5  0x00007f08e6cdd61a in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#6  0x00007f08e6ce232f in ?? () from /usr/lib64/libQt5Core.so.5
#7  0x00007f08dcb6c0a4 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f08e63dafed in clone () from /lib64/libc.so.6
 
Thread 3 (Thread 0x7f083ffff700 (LWP 2083)):
#0  0x00007f08e63d2bbd in poll () from /lib64/libc.so.6
#1  0x00007f08dc64fe64 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f08dc64ff7c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f08e6f14d8b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#4  0x00007f08e6ebbd53 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#5  0x00007f08e6cdd61a in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#6  0x00007f08e6ce232f in ?? () from /usr/lib64/libQt5Core.so.5
#7  0x00007f08dcb6c0a4 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f08e63dafed in clone () from /lib64/libc.so.6
 
Thread 2 (Thread 0x7f08bd87d700 (LWP 2085)):
#0  0x00007f08e63d2bbd in poll () from /lib64/libc.so.6
#1  0x00007f08dc64fe64 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f08dc64ff7c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f08e6f14d8b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#4  0x00007f08e6ebbd53 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#5  0x00007f08e6cdd61a in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#6  0x00007f08e6ce232f in ?? () from /usr/lib64/libQt5Core.so.5
#7  0x00007f08dcb6c0a4 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f08e63dafed in clone () from /lib64/libc.so.6
 
Thread 1 (Thread 0x7f08e93d6800 (LWP 1627)):
[KCrash Handler]
#6  0x00007f08e8c0e410 in ?? () from /usr/lib64/libkmailprivate.so.5
#7  0x00007f08e8c41580 in KMMainWidget::updateMessageActionsDelayed() () from /usr/lib64/libkmailprivate.so.5
#8  0x00007f08e8c41dd5 in KMMainWidget::updateMessageActions(bool) () from /usr/lib64/libkmailprivate.so.5
#9  0x00007f08e8c535b1 in KMMainWidget::setupActions() () from /usr/lib64/libkmailprivate.so.5
#10 0x00007f08e8c58775 in KMMainWidget::KMMainWidget(QWidget*, KXMLGUIClient*, KActionCollection*, QExplicitlySharedDataPointer<KSharedConfig>) () from /usr/lib64/libkmailprivate.so.5
#11 0x00007f08e8c00584 in ?? () from /usr/lib64/libkmailprivate.so.5
#12 0x00007f08e8c13815 in KMKernel::openReader(bool) () from /usr/lib64/libkmailprivate.so.5
#13 0x00007f08e8c1bae0 in KMKernel::action(bool, bool, QString const&, QString const&, QString const&, QString const&, QString const&, QUrl const&, QList<QUrl> const&, QStringList const&, QString const&, QString const&) () from /usr/lib64/libkmailprivate.so.5
#14 0x00007f08e8c1d1f5 in KMKernel::handleCommandLine(bool, QStringList const&, QString const&) () from /usr/lib64/libkmailprivate.so.5
#15 0x0000000000404e63 in KMailApplication::activate(QStringList const&, QString const&) ()
#16 0x00007f08e9029f32 in KontactInterface::PimUniqueApplication::newInstance(QByteArray const&, QStringList const&, QString const&) () from /usr/lib64/libKF5KontactInterface.so.5
#17 0x00007f08e902b132 in ?? () from /usr/lib64/libKF5KontactInterface.so.5
#18 0x00007f08e902b4e3 in KontactInterface::PimUniqueApplication::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libKF5KontactInterface.so.5
#19 0x00007f08e53a2da4 in ?? () from /usr/lib64/libQt5DBus.so.5
#20 0x00007f08e53a7372 in ?? () from /usr/lib64/libQt5DBus.so.5
#21 0x00007f08e53a7d22 in ?? () from /usr/lib64/libQt5DBus.so.5
#22 0x00007f08e53a992e in ?? () from /usr/lib64/libQt5DBus.so.5
#23 0x00007f08e6eeeac6 in QObject::event(QEvent*) () from /usr/lib64/libQt5Core.so.5
#24 0x00007f08e740c382 in QGuiApplication::event(QEvent*) () from /usr/lib64/libQt5Gui.so.5
#25 0x00007f08e808512c in QApplication::event(QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#26 0x00007f08e8081e7c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#27 0x00007f08e8086cc8 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#28 0x00007f08e6ebde95 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQt5Core.so.5
#29 0x00007f08e6ec0057 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQt5Core.so.5
#30 0x00007f08e6f158f3 in ?? () from /usr/lib64/libQt5Core.so.5
#31 0x00007f08dc64fc84 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#32 0x00007f08dc64fed8 in ?? () from /usr/lib64/libglib-2.0.so.0
#33 0x00007f08dc64ff7c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#34 0x00007f08e6f14d6c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#35 0x00007f08e6ebbd53 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#36 0x00007f08e7cce25e in KJob::exec() () from /usr/lib64/libKF5CoreAddons.so.5
#37 0x00007f08e8c13ef6 in KMKernel::cleanup() () from /usr/lib64/libkmailprivate.so.5
#38 0x000000000040452a in main ()

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2721

Prova a fare una ricerca sul forum:
https://forums.opensuse.org/forum.php
Volevo sapere se c'è nella Leap:
esegui_comando, dove ti si apre una finestrella ed vai ad inserire quello che ti serve da fare. Wink
è comodissimo.

SUSE Tumbleweed- kernel-5.1.4-1.2- kde-plasma-5.15.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di Dr.Slump
Dr.Slump
(Junior)
Offline
Junior
Iscritto: 08/11/2014
Messaggi: 26

un paio di settimane fa ho abilitato il repository "framework5" e aggiornato KDE, adesso non riesco piu' a fare update perche' manca sempre una dipendenza e non trovo il repository che dovrebbe fornire questo pacchetto, il messaggio di zypper e':

Problema: nessun elemento fornisce libQt5Core.so.5(Qt_5.6)(64bit) obbligatorio per kactivitymanagerd-5.6.0-1.1.x86_64
Soluzione 1: mantenere kactivitymanagerd-5.5.95-3.1.x86_64 obsoleto
Soluzione 2: interrompere kactivitymanagerd-5.6.0-1.1.x86_64 ignorandone alcune dipendenze

se rispondo 1 tenta di downgradarmi tutto KDE alla versione precedente....

Ritratto di Raff82
Raff82
(Geek)
Offline
Geek
Iscritto: 30/03/2011
Messaggi: 151

Dr.Slump ha scritto:

un paio di settimane fa ho abilitato il repository "framework5" e aggiornato KDE, adesso non riesco piu' a fare update perche' manca sempre una dipendenza e non trovo il repository che dovrebbe fornire questo pacchetto, il messaggio di zypper e':

Problema: nessun elemento fornisce libQt5Core.so.5(Qt_5.6)(64bit) obbligatorio per kactivitymanagerd-5.6.0-1.1.x86_64
Soluzione 1: mantenere kactivitymanagerd-5.5.95-3.1.x86_64 obsoleto
Soluzione 2: interrompere kactivitymanagerd-5.6.0-1.1.x86_64 ignorandone alcune dipendenze

se rispondo 1 tenta di downgradarmi tutto KDE alla versione precedente....

Prova ad aggiungere anche il repository per libQt 5.6:

http://download.opensuse.org/repositories/KDE:/Qt56/openSUSE_Leap_42.1/

Dovrebbe andare bene anche il repository per le LibQt generiche, visto che punta all'ultima 5.6:

http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_42.1/

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2721

http://download.opensuse.org/repositories/KDE:/
http://download.opensuse.org/repositories/
ciao

SUSE Tumbleweed- kernel-5.1.4-1.2- kde-plasma-5.15.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 878

Non ho Kde , ma io andrei di soluzione 2