XGL con schede ATI: Installare driver, abilitare 3D, Attivare XGL

2 risposte [Ultimo messaggio]
Ritratto di marcocento
marcocento
(Junior)
Offline
Junior
Iscritto: 03/07/2006
Messaggi: 23

Ciao.. sono ancora Marco Love Struck
Sarò sincero: ho scaricato e provato SUSE Enterprise Desktop 10 SOLO perché mi piacevano da matti gli effetti di XGL.
L'ho scoperdo vedendo da Google Video questo video.
Ovviamente non provo nemmeno a vedere se funziona da VMWare perché sarebbe un fiasco sicuro credo..
Così ho installato realmente su disco e ho iniziato a smanettare.

Il mio PC ha le seguenti caratteristiche:
- Processore: AMD Athlon 64 3800+
- RAM: 1GB
- Scheda madre: ABIT (KN8 Ultra/KN8)
- Scheda video: ATI Radeon x550

Attivando XGL dal "Centro di controllo" il messaggio diceva che non erano abilitate le funzionalità 3D ma andando attraverso Yast a configurare la scheda video la spunta per abilitare il 3D era oscurata (non si poteva cliccare).

Così ho cercato come fare ad abilitare la cosa e ho scoperto che dovevo installare un driver particolare.
Per le schede NVidia c'è una fantastica guida a questo indirizzo che spiega tutto in dettaglio ma non trovo nulla di analogo per le schede ATI. L'unico che ho trovato a questo indirizzo spiega come installare i driver ATI ma quando si devono fare le opportune configurazioni dice semplicemente di digitare:
aticonfig --initial --input=/etc/X11/xorg.conf
Facendolo dopo il riavvio mi ritrovo un nuovo "monitor ATI" ma se lo attivo mi dice che il file xorg.conf è incompleto e manca qualcosa.

Qualcuno sa spiegarmi passo per passo come devo fare ad installare i giusti driver e fare le opportune configurazioni per provare XGL?

Grazie mille, Marco.

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Dopo aver dato il comando aticonfig --initial --input=/etc/X11/xorg.conf sulle altre discussioni c'e` scritto di dare anche il comando sax2 -r -m 0=fglrx e dopo, per sicurezza, fare un reboot.
Prova, magari e` proprio quello che ti manca.

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di marcocento
marcocento
(Junior)
Offline
Junior
Iscritto: 03/07/2006
Messaggi: 23

Laughing GRANDISSIMO!
Credo che era proprio quello che mancava.
Allora: riassumiamo i fatti.

Il problema
Non era possibile abilitare le funzionalità 3D
Non era installato un driver aggiornato della scheda grafica

1) Ho scaricato questo file dal sito dell' ATI

2) Ho impostato sul file tutti i diritti (lettura scrittura esecuzione ecc ecc) digitanto da riga di comando chmod 777 [nomefile]

3) Ho eseguito il file da root (su) digitando ./[nomefile] nella cartella di download

4) Nella finestra che è comparsa ho seguito il percorso per creare un RPM per SUSE 10.1

5) Creato l'RPM ho impostato tutti i diritti (come prima)

6) Ho installato l'RPM semplicemente cliccandoci sopra 2 volte

7) Terminata l'installazione ho riavviato il PC

8) Ho digitato i 2 seguenti comandi da shell ("loggato" come root):
aticonfig --initial --input=/etc/X11/xorg.conf
sax2 -r -m 0=fglrx

9) Ho riavviato il PC

Adesso ho tra le applicazioni una "nuova applicazione" che è un tool per configurare la scheda grafica.
In Yast finalmente è possibile abilitare il 3D.
Il tool per avviare gli effetti di XGL dice che la scheda grafica non è nel database ma riconosce che è abilitata la voce 3D permettendo quindi di attivare gli "effetti" XGL.
Riavviando il PC dopo aver attivato XGL vedo immagini per brevissimi istanti seguiti da schermate nere... dopo un po' mi si presenta il login in modalità testuale e non grafica.
Se disabilito XGL digitando da root
gnome-xgl-switch --disable-xgl
riparte tutto con il login grafico ma senza XGL.

Credo di essere ad un punto fermo.. Thinking meglio attendere che XGL sia più diffuso e che la mia scheda sia nei database.. sbaglio? Un piccolo appello: se qualcuno ha una scheda grafica ATI Radeon x550 ed è riuscito ad attivare XGL mi spiega come? Grazie mille

Marco