Connettersi a internet con telefonino GPRS/UMTS tramite USB

Dom, 10/06/2007 - 12:14

Connettersi a internet con telefonino GPRS/UMTS tramite USB

Inviato da anubis 24 commenti

Collegate il Vostro cellulare alla porta usb del personal computing
(Se avete un telefonino nokia dovrebbe essere immediatamente riconosciuto come modem). Potete ora verificare il riconoscimento andando su Yast/rete/modem.

Oppure più semplicemente aprite una shell e digitate:

$ lsusb

se ottenete qualcosa di simile a questo:

anubis@pc-anubis:~$ lsusb
Bus 005 Device 001: ID 0000:0000
Bus 001 Device 002: ID 0421:043a Nokia Mobile Phones
Bus 001 Device 001: ID 0000:0000
Bus 003 Device 003: ID 045e:00a4 Microsoft Corp.
Bus 003 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 002 Device 005: ID 1110:9021 Analog Devices Canada, Ltd (Allied Telesyn)
Bus 002 Device 001: ID 0000:0000
Come vedete dalla risposta della shell il telefono è stato riconosciuto .Non resta che configurare opensuse.
Abbiamo tre modi diversi per collegarci a voi la scelta:
WvDial, Kppp, Gnomeppp

Collegamento con WvDial

Aprite una shell e digitate:

$ sudo gedit /etc/wvdial.conf

Sostituite il contenuto del file wvdial.conf con questo.

[Dialer Defaults]
Modem = /dev/ttyACM0
Baud = 460800
Init1 = ATZ
Init2 = AT+CGDCONT=1,"IP","ibox.tim.it",,0,0
ISDN = 0
Modem Type = Analog Modem
Carrier Check = no
Phone = *99#
Username = ''
Password = ''
L'esempio tratta il caso di una connessione con Tim come provider. Per altri operatori basta sostituire l'APN (nell'esempio, ibox.tim.it) con l'APN dell'operatore in questione, come anche il numero da chiamare (trovate una lista in fondo alla pagina).nota

Salvare e uscire dall'editor di testo.

Per connettersi basta digitare

$ wvdial

sul terminale. Per disconnettersi, basta premere la combinazione di tasti Ctrl+C sul terminale in cui è stato wvdial.

Collegamento con Gnome ppp
Connettersi con wvdial può risultare scomodo. Un modo per ovviare a questo problema potrebbe essere l'utilizzo dell'applicazione gnome-ppp
Fatelo partire. Ora nei campi Username e Password si può inserire ciò che si desidera, non è rilevante. Nel campo Numero di telefono invece è necessario inserire *99#(o quello del vostro operatore, se diverso).

Cliccate ora su «Configura»:

nella finestra Modem digitate nella cella dispositivo /dev/ttyAMC0
fatto questo cliccate su «Stringhe di inizializzazione» per ottenere una nuova finestra:

se trovate già scritto qualcosa non preoccupatevi! doppio clic, cancellate tutto e scrivete AT+CGDCONT=1,"IP","ibox.tim.it",,0,0 come visto per wvdial.conf.

Chiudete questa finestra, selezionare la scheda «Opzioni» togliete la spunta da Controlla carrier line.

Ora si può procedere con la connessione. Basta cliccare su «Connetti» nella prima finestra di gnome-ppp.

Collegamento con Kppp

Se wvdial non è scomodo e non vi piace gnome. Bhè allora vi resta solo una cosa da fare. Usare Kppp.

Nei campi "Username" e "Password" si può inserire ciò che si desidera, non è rilevante. Procediamo ora a configurare il modem e l'operatore.

Cliccare su «Configura», e nella scheda Account cliccare su Nuovo:

Come nome connessione inseriamo quello che vogliamo e come Numero di telefono aggiungiamo *99#(o quello del vostro operatore se diverso). Confermiamo con OK.

Cliccare su Nuovo nella scheda Modem:

Scegliamo il nome del modem e come Dispositivo Modem scegliamo /dev/ttyACM0.

Cliccare su Modem e poi su Comandi Modem:

aggiungiamo AT+CGDCONT=1,"IP","ibox.tim.it",,0,0 <7b> come visto per wvdial.conf.

Ora si può procedere con la connessione. Basta cliccare su «Connetti» nella prima finestra di kppp.

ATTENZIONE! se non dovesse andare provate così:

se il vostro operatore vi dice che non avete bisogno di user e password allora cancellateli dalla schermata principale di kppp dopo di chè cliccate su configura, selezionate l'account che avete creato e cliccate su modifica, bene dove dice autenticazione selezionate via terminale o via script sono lo stesso per quello che ci riguarda. Ora connettetevi come prima!

si ora dovrebbe andare!

Lista APN e numeri di connessione per Operatori di telefonia mobile

Se non avete Tim come nel mio esempio dovee sostituire questi APN e numeri telefonici nelle varie configurazioni:

1) Tim: ibox.tim.it
2) Vodafone: web.omnitel.it
3) Wind: internet.wind
3b.)Wind (numero da comporre): *99***1#
4)H3G: apn.tre.it
5)con opzione "Naviga 3"abbiamo questa stringa di inizializzazione Init2 = AT+CGATT=0,"IP","naviga.tre.it",,0,0

ATTENZIONE! Non rispondo di eventuali danni all'utilizzo di questa guida.

:
Ciao





Commenti

Ritratto di robysuse
#1

Inviato da robysuse il Mar, 24/03/2009 - 13:58.

Re: Nokia 6680 su suse 11.1

Ciao, sono sempre io...
ho seguito le tue indicazioni però ora quando provo a connettermi mi da questo msg nella finestra di debug:
"AT+CGDCONT=1,"IP","ibox.tim.it",,0,0 <7b>
ERROR"
puoi aiutarmi?
Grazie



Ritratto di anubis
#2

Inviato da anubis il Mar, 24/03/2009 - 14:31.

Re: Nokia 6680 su suse 11.1

elimina <7b> .. voleva essere "</b>" il tag per chiudere il grassetto

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el



Ritratto di robysuse
#3

Inviato da robysuse il Mar, 24/03/2009 - 15:28.

Re: Nokia 6680 su suse 11.1

Adesso il modem si collega però non riesco a collegarmi ad internet, puoi ancora aiutarmi? Grazie Big Grin



Ritratto di anubis
#4

Inviato da anubis il Mar, 24/03/2009 - 16:52.

Re: Nokia 6680 su suse 11.1

controllati i dns?

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el



Ritratto di robysuse
#5

Inviato da robysuse il Mer, 25/03/2009 - 10:42.

Re: Nokia 6680 su suse 11.1

Grazie della consulenza, si connette e si collega.
Un'ultima cosa, la connessione dura pochi minuti e poi si scollega...
dipende da tim o va modificato qualche altro parametro?
Sto usando suse 11.1, kde 4.2 e kppp.
Grazie



Ritratto di Safraco
#6

Inviato da Safraco il Sab, 20/06/2009 - 00:21.

H3G Naviga TRE [was Re: precisazioni]

Posto il mio /etc/wvdial.conf funzionante :idea: con naviga 3 e samsung sgh-j630 su opensuse 11.1 Linux linux-l3zg 2.6.27.23-0.1-pae #1 SMP 2009-05-26 17:02:05 -0400 i686 i686 i386 GNU/Linux

<br />[Dialer Defaults]<br />Modem = /dev/ttyACM0<br />Baud = 460800<br /><i><b>Init1 = AT+CGATT=0</b></i><br />Init2 = AT+CGDCONT=1,&quot;IP&quot;,&quot;naviga.tre.it&quot;<br />Init3 =<br />Area Code =<br />Phone = *99#<br />Carrier Check = no<br />Username = &#039;&#039;<br />Password = &#039;&#039;<br />Ask Password = 0<br />Dial Command = ATDT<br />Stupid Mode = 1<br />Compuserve = 0<br />Force Address =<br />Idle Seconds = 300<br />DialMessage1 =<br />DialMessage2 =<br />ISDN = 0<br />Auto DNS = 0<br />

Settati i dns nel file /etc/resolv.conf poichè non andava con i dns in automatico (infatti, noterai, che il valore "auto DNS" e' settato su "0".

<br />nameserver 208.67.222.222<br />nameserver 208.67.220.220<br />

Si ringrazia quest'articolo per la soluzione.
wdial infatti dava bad string come output se si usa la prima stringa di inializzazione come da guida.
Chiedo venia se qualcuno aveva gia' postato la soluzione da qualche parte.

Credo che questo risolva anche il problema riscontrato da Margherita.

L'aspetto piu' simpatico e' con window$ xp non c'e' stato verso di farlo andare, neanche col software naviga tre... vabbè gli ho dedicato molto meno tempo, volevo solo vedere se andava, comunque nulla ha funzionato out of the box Wink

Ciriciao. 8-)

Chi va per il sentiero si annoia.



Ritratto di anubis
#7

Inviato da anubis il Mer, 10/10/2007 - 23:03.

piccola soluzione

per usare wvdial da utente senza modificare i sudoers basta aggiungere il vostro utente al gruppo UUCP

avrete accesso ora al modem TTYAMC0

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el



Ritratto di robermann79
#8

Inviato da robermann79 il Lun, 15/10/2007 - 23:59.

H3G e DNS

Ciao
Grazie alla guida, sono riuscito a connettermi usando Naviga3 di tre appunto. Ecco la configurazione di wvdial:
<br />[Dialer Defaults]<br />Modem = /dev/ttyACM0<br />Baud = 460800<br />Init1 = ATZ<br />Init2 = AT+CGATT=0,&quot;IP&quot;,&quot;naviga.tre.it&quot;,,0,0<br />Init3 =<br />Area Code =<br />Phone = *99#<br />Carrier Check = no<br />Username = &#039;&#039;<br />Password = &#039;&#039;<br />Ask Password = 0<br />Dial Command = ATDT<br />Stupid Mode = 1<br />Compuserve = 0<br />Force Address =<br />Idle Seconds = 300<br />DialMessage1 =<br />DialMessage2 =<br />ISDN = 0<br />Auto DNS = 1<br />

L'unico problema è stato il DNS: quando avvio wvdial compare il messaggio
<br />--&gt; local  IP address 1.133.2.192<br />--&gt; remote IP address 10.64.64.64<br />--&gt; primary   DNS address 10.11.12.13<br />--&gt; secondary DNS address 10.11.12.14<br />--&gt; Script /etc/ppp/ip-up run successful<br />--&gt; Default route Ok.<br />--&gt; warning, can&#039;t find address for `www.suse.de`<br />--&gt; warning, address lookup does not work<br />--&gt; Nameserver (DNS) failure, the connection may not work.<br />--&gt; Connected... Press Ctrl-C to disconnect<br />
Mi vengono cioe' aggiunti due DNS che non funzionano...
L'ho risolto modificando a mano il file /etc/resolve.conf,
sostituendo i nameserver presenti con i due che seguono:
<br />nameserver 62.13.171.1<br />nameserver 62.13.171.2 <br />
(grazie a http://www.debianclan.org/index.php?option=com_content&task=view&id=154&Itemid=3)

Ora posso navigare tranquillamente Smile
Se c'e' una soluzione piu' elegante ben venga; mi accontenterei di sapere perche' i server 10.11.12.13 e 10.11.12.14 non funzionano. Inoltre, come mai io ho un indirizzo della serie 1.X, mentre i DNS stanno su 10.X ?

ciao
rob



Ritratto di darko
#9

Inviato da darko il Ven, 21/03/2008 - 06:09.

Re: H3G e DNS

ciao scusa ma ho bisogno di aiuto hai un modem momo design?se si mi mandi un email a darkosoul71@gmail.com,non riesco a navigare non me lo vede è 4 notti che non dormo se hai qualche consiglio e mi spieghi passo passo te ne sarei molto grato alla prossima :-P



Ritratto di robermann79
#10

Inviato da robermann79 il Mar, 25/03/2008 - 11:59.

Re: H3G e DNS

Ciao, no non ho quel tipo di modem.
Forse un programma grafico potrebbe essere piu' di aiuto: hai provato GPRS easy connect?
http://packages.opensuse-community.org/index.jsp?searchTerm=gprs

Ad ogni modo, se non ti vede la porta potrebbe essere un problema di permessi.

da root, lancia un brutale
chmod 777 /dev/ttyACM0

La porta /dev/ttyACM0 dovrebbe comparire solo quando attacchi lo spinotto USB.

Ciao
rob

Quote:

ciao scusa ma ho bisogno di aiuto hai un modem momo design