Installare è configurare VMware Workstation in suse 10.1

Mar, 17/10/2006 - 19:24

Installare è configurare VMware Workstation in suse 10.1

Inviato da Alfio 30 commenti

Prima di tutto ci serve Vmware che scarichiamo da qui:
http://download3.vmware.com/software/wkst/VMware-workstation-5.5.0-18463.i386.rpm

Poi scarichiamo l'aggiornamento da qui:
http://ftp.cvut.cz/vmware/vmware-any-any-update104.tar.gz

Si suppone che abbiate installato le librerie di compilazione :
kernel-source | 2. gcc | 3. gcc-c++ | 4. make
Se non è cosi provvedete a farlo.

Ora che abbiamo l'occorrente iniziamo con l'rpm installandolo con Yast o zen o per chi preferisce da consolle con il comando rpm -ivh da root.

Fatto ciò spostiamoci dove cè l'archivio che abbiamo scaricato:
cd /home/nomeutente/directory dell'archivio.

Scompattiamo il fil file:
tar -xzf vmware-any-any-update104.tar.gz

Lanciamo lo script con il comando:
./runme.pl

Una volta lanciato lo script configuriamolo accettando la licenza d'uso è cosi via.
Seguite le istruzioni con le affermazioni o negazioni che lo script vi consiglia escluso per il nat non abilitatelo.

ATTENZIONE!
Per ogni aggiornamento del kernel dovete rifare la configurazione.

ATTENZIONE!

VMware Workstation è un programma a pagamento potete utilizzarlo per 30 giorni dopo di che se non acquistate la licenza d'uso smetterà di funzionare diventando solo VMplayer.

Se volete comprarlo acquistando il seriale andate alla pagina ufficiale di VMplayer da qui:
http://www.vmware.com/company/office_california.html

Ciao


In:



Commenti

Ritratto di Alfio
#1

Inviato da Alfio il Dom, 25/02/2007 - 18:37.

Re: Porte usb in VMware abilitate all'avvio

se hai slavato la cartella o detto disco virtuale copialo nell'home di root e poi da vmware lo fai avviare.
scegliendo non una nuova macchina ma una esistente.
Ciao



Ritratto di gianfry
#2

Inviato da gianfry il Dom, 25/02/2007 - 18:58.

Re: Porte usb in VMware abilitate all'avvio

non riesco a creare la cartella da utente xchè mi dice che non ho i permessi x dev/hda e da root mi crea il problema della schermata blu



Ritratto di gianfry
#3

Inviato da gianfry il Lun, 26/02/2007 - 00:22.

Re: Porte usb in VMware abilitate all'avvio

ho risolto,xp native ora parte ma solo da root,bisognava creare un nuovo profilo all'interno di xp native.

mi resta il prob. di non riuscire a farlo partire da utente,nemmeno inserendomi come utente anche i privilegi disk.

Tu ne sai qulcosa in + ?



Ritratto di fsf_dipendente
#4

Inviato da fsf_dipendente il Dom, 30/09/2007 - 08:46.

Re: Porte usb in VMware abilitate all'avvio

Premetto che ho scritto la stinga dettaci da Alfio in fstab.
E che ho suse10.1(host) con WinXP(guest).

Quando monto l'HD usb sotto WinXP si smonta da linux. E' possibile evitarlo?

Io seguo questa procedura:
-monto l'HD usb sotto linux e lo vedo perfettamente
-avvio la VM WinXP e carico l'OS (WinXP appunto)
-attacco con VMware l'HD usb a WinXP con VM->Removable Devices ->USB Devices->[Nome del mio HD usb].

A questo punto VMware genera il messaggio:

The specified device appears to be claimed by another driver (usb-storage) on the host operating system which means that the device may be in use. To continue, the device will first be disconnected from its current driver.

Al quale rispondo ok.
L'HD usb viene rilevato da WinXP e mi funziona bene.

Però rispondendo Ok al messaggio precedente, VMware mi smonta l'HD usb da linux, cosa che vorrei evitare.
Ho controllato, sotto linux non mi risulta presente nessuna periferica /dev/sd[a-z] oppure /dev/sd[a-z]1.

In realtà la stessa cosa mi succede se seguo quest'altra procedura

-avvio linux (con l'HD usb staccato)
-avvio la VM WinXP e carico l'OS
-attacco fisicamente l'HD usb
-WMware mi visualizza lo stesso messaggio di prima e tutto è esattamente come prima.

Io vorrei vedere L'HD contemporaneamente sotto linux e WinXP. E' possibile??
Se con VMware non è possibile, sapete se lo è con Virtual Box?
Grazie

opensuse 11.4
kernel 2.6.37.1-1.2-desktop
kde 4.6



Ritratto di mardurhack
#5

Inviato da mardurhack il Ven, 03/11/2006 - 18:44.

errore...

mi da un errore dicendo che non può compilare il modulo vmmon...come faccio? allego una schermata della shell...
EDIT: RISOLTO (Aggiornare prima di configurare! Aggiornare PRIMA DI CONFIGURAREE!!) Laughing

Questo ancora non l'ho risolto...
Altra piccola domanda..come faccio a dire a Kpackage (yast sballa con gli rpm!) di estrarre i file dall'RPM in /home/programs/NOMEDELPROGRAMMA??? Thanks Wink

"Tu vedi cose e ne spieghi il perché, io invece immagino cose che non sono mai esistite e mi chiedo...Perché no?" G.B. Shaw :idea:



Ritratto di Alfio
#6

Inviato da Alfio il Dom, 05/11/2006 - 10:38.

Re: errore...

Si fa l'aggiornmento proprio per questo problema di vmmon...
Non ho capito cosa intendi per rpm....
Ciao



Ritratto di mordecai
#7

Inviato da mordecai il Ven, 17/11/2006 - 21:47.

Re: errore...

EHI ragazzi!Nel punto in cui la guida dice:

"Fatto ciò spostiamoci ddove cè l'archivio che abbiamo scaricato:
cd /home/nomeutente/directory dell'archivio.
"

Ho visto i file installati da rpm,e le path sono diverse:

-/etc/vmware
/etc/vmware/installer.sh

-/usr/bin/vm-support
/usr/bin/vmnet-bridge
/usr/bin/vmnet-dhcpd
/usr/bin/vmnet-natd
/usr/bin/vmnet-netifup
/usr/bin/vmnet-sniffer
/usr/bin/vmplayer
/usr/bin/vmware-config.pl
/usr/bin/vmware-ping

e anche tantissimissimi pacchetti installati in:
-/usr/lib/vmware

Dove mi devo posizionare???

:-o



Ritratto di Alfio
#8

Inviato da Alfio il Ven, 17/11/2006 - 22:40.

Re: errore...

forse cosi ti viene piu' semplice.
Scompatta l'aggiornamento (tasto destro e poi usa il programma per scompattare) verra' creata una cartella .
Apri una consolle trascinala dentro ed si aprira' un menu a tendina scegli cd.
Loggati da root e poi lancia il comando dello script
Ciao



Ritratto di mordecai
#9

Inviato da mordecai il Ven, 17/11/2006 - 22:42.

Re: errore...

Quando trascino la cartella nn appare nessun menù a tendina....

p.s. ma io ho creato una macchina virutale XEN,e all'avvio mi appare oltre a linux,linux failsafe,anche xen linux.
Deve scegliere quello vero?è necessario?



Ritratto di Alfio
#10

Inviato da Alfio il Ven, 17/11/2006 - 22:45.

Re: errore...

Xen è una cosa wmware è un'altra pur avendo in comune la virtualita'.
Ti ha creato xen in grub l'avvio per kernel per xen.
Ciao