Problema pacchetto xorg-x11-server

Ven, 18/01/2008 - 23:31

Problema pacchetto xorg-x11-server

Inviato da anubis 28 commenti

Ieri è stato rilasciato un aggiornamento del pacchetto xorg-x11-server

questo aggiornamento è per la precisione xorg-x11-server-7.2-143.9

che dovrebbe risolvere diversi bug sulla sicurezza. Il problema è che risolve questi bug, ma ne porta dietro degli altri. A tale proposito vi segnalo questo bug su bugzilla:

https://bugzilla.novell.com/show_bug.cgi?id=354615

Il problema è stato segnalato sul nostro forum in questo 3d:

http://www.suseitalia.org/modules/newbb/viewtopic.php?topic_id=16169&start=0

in cui come potete notare si ottiene lo stesso errore ricevuto da vlc nella pagina di bugzilla.

Oltre a ciò, può succedere. come nel mio caso, che vengano rotti i drivers nvidia. Sembra infatti che un link simbolico venga rotto:

direttamente dai miei log:
Quote:

ERROR: File '/usr/lib/xorg/modules/extensions/libglx.so' is not a symbolic
link.

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling RENDER acceleration
(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0): log file that the GLX module has been loaded in your X
(EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
(EE) NVIDIA(0): you continue to encounter problems, Please try
(EE) NVIDIA(0): reinstalling the NVIDIA driver.

questo provoca una impossibilità di avviare una sessione grafica funzionante... quando si raggiunge il runlevel 5 (init 5) lo scermo inizia a lampeggiare come le luci di natale!

ecco le soluzioni!

1) NON INSTALLARE L'AGGIORNAMENTO (ovvio)
2) PROBLEMA VLC/AMULE ecc..

fare il downgrade del pacchetto alla versione xorg-x11-server-7.2-143.6

per i conflitti procedete come segue:

a) selezionate la versiona corretta
Cool accettate a cancellare xorg-x11-server
c) ignorate la mancanza del requisito globalmente

ora dovreste essere ok

3) problemi drivers nvidia:

avviamo il pc, e quando ci troviamo difronte a grub digitiamo 3 (apparirà nelle opzioni di boot) in questo modo avvieremo il pc in init 3, fate il login e quindi avviate la sessione con startx.

avviate amule e vlc, se funzionano vi basterà reinstallare i drivers nvidia se non funzionano fate il downgrade del pacchetto xorg-x11-server quindi reinstallare i drivers nvidia.

spero di essere stato utile..

vi farò sapere per ulteriori novità, seguo personalmente questo bug.





Commenti

Ritratto di anubis
#1

Inviato da anubis il Ven, 18/01/2008 - 23:39.

Re: Problema pacchetto xorg-x11-server

1) il problema sembra affliggere anche ubuntu:

http://www.suseitalia.org/modules/newbb/viewtopic.php?topic_id=16169&start=6

2) auris o alfio..cambiate il [ /code] in [ /quote]??? grazie

--edit--

grazie

---edit---

il bug è stato segnalato come un duplicato di questo:

https://bugzilla.novell.com/show_bug.cgi?id=345131

la "discussione" continua a questo link

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el



Ritratto di pinguinopaesano
#2

Inviato da pinguinopaesano il Sab, 19/01/2008 - 00:34.

Re: Problema pacchetto xorg-x11-server

Ci provo a fare il downgrade...

ho disattivato il repo degli aggornamenti, ma mi da solo l'opzione di ELIMINARE xorg-x11-server.

:cry:



Ritratto di anubis
#3

Inviato da anubis il Sab, 19/01/2008 - 00:54.

Re: Problema pacchetto xorg-x11-server

Quote:

per i conflitti procedete come segue:

a) selezionate la versiona corretta
Cool accettate a cancellare xorg-x11-server
c) ignorate la mancanza del requisito globalmente

---edit---

ovviamente il repo degli aggiornamenti deve essere attivo dato che è da li che prendi il pacchetto precedente

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el



Ritratto di pablhobbit
#4

Inviato da pablhobbit il Sab, 19/01/2008 - 04:59.

Re: Problema pacchetto xorg-x11-server

domanda idiota: il pacchetto si può prendere anche dal DVD di Suse?



Ritratto di Bobreggae
#5

Inviato da Bobreggae il Sab, 19/01/2008 - 07:31.

Re: Problema pacchetto xorg-x11-server

Grazie Anubis, risolto!!!



Ritratto di Kff_ffK
#6

Inviato da Kff_ffK il Dom, 20/01/2008 - 11:29.

Re: Problema pacchetto xorg-x11-server

Grazie 1000 Anubis, con il downgrade di Xorg da te suggerito ho risolto il problema con il ciuchino.
Alla prossima.

OpenSuse Leap 15.2 64-bit
- Versione di KDE/Plasma: 5.18.6 - Versione di KDE Frameworks: 5.71.0
- Versione di Qt: 5.12.7 - Versione del Kernel: 5.3.18-lp152.60-default



Ritratto di Alfio
#7

Inviato da Alfio il Mer, 23/01/2008 - 21:11.

Re: Problema pacchetto xorg-x11-server

E' stata rilasciata la nuova patch 7.2.143.11
ciao



Ritratto di anubis
#8

Inviato da anubis il Mer, 23/01/2008 - 21:21.

Re: Problema pacchetto xorg-x11-server

mi hai anticipato!

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el



Ritratto di Alfio
#9

Inviato da Alfio il Mer, 23/01/2008 - 21:27.

Re: Problema pacchetto xorg-x11-server

Laughing :-P



Ritratto di Bobreggae
#10

Inviato da Bobreggae il Gio, 24/01/2008 - 10:30.

Re: Problema pacchetto xorg-x11-server

quindi ora i 2 aggiornamenti di xorg-x11 si possono installare tranquillamente?